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CHAPTER 9  INDEXING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

An index is an alphabetical listing of the topics or subjects in a 
document, and is typically located at the end of a document. An 
index is used primarily as a navigational tool, with the 
corresponding page number(s) for each topic listed alongside.  

In this session you will: 

 gain an understanding of indexing 

 learn how to mark index entries 

 learn how to create an AutoMark file 

 learn how to use an AutoMark file 

 learn how to delete unwanted index entries 

 learn how to generate an index 

 learn how to modify the index format 

 learn how to update an index. 

INFOCUS 

WPL_W853 
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UNDERSTANDING INDEXING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As well as including a table of contents in long 
documents, consider also including an index at 
the end of the document. While a table of 
contents enables the reader to navigate to certain 

sections, for example, a well-constructed index will 
help the reader to locate all information about a 
specific topic within that document, by providing a 
detailed listing of the topics within the document. 

What Is An Index? 

An index is an alphabetical and detailed listing of topics in a document, with a corresponding page 
number displayed alongside (see picture below). An index is typically located at the end of a long 
document. An index helps readers to navigate long documents and locate specific information they 
may need. For example, you might refer to an index to locate all references to solar panels in a 
document about being environmentally-friendly at home. Unlike a table of contents, which lists 
headings and sections, for example, an index is based on specific terms and topics, making it a 
more detailed reference to the information in the document.  

Another advantage of including an index is being able to create several index entries for a single 
topic. This can be useful, as people may use different terms to describe the same thing, for example 
sun and solar energy. By including both of these entries in the index, there is a much greater 
chance that readers will find the information they’re looking for, despite not knowing the specific term 
used throughout the document. 

Generating An Index 

You build an index by marking text to include with a special field, called an index field {XE}.This 
field tells Word to include the marked text as an index entry. You can create an index manually by 
marking all relevant text throughout the document, or you can create an AutoMark file, which Word 
will use to mark the entries throughout the document automatically on your behalf. 

The obvious advantage of creating an index manually is that you have total control over the 
process, and can ensure accuracy of index entries. You also determine what text is marked to 
include in the index.  

To help Word generate an index automatically, you need to create an AutoMark file, which is a 
two-column table. The first column lists the text to be marked, and the second column contains the 
corresponding index entry. The document is then cross-referenced with the AutoMark file, and all 
text that matches the data in the first column will be marked. This method, although a quick way to 
index a long document, does not offer a large degree of control; you might find yourself spending 
time deleting and adding field codes.  

An advantage of using an AutoMark file is that you can mark any number of documents using the 
same table of data. If many of your documents are quite similar in topic matter, this could prove 
quite useful. Following this, you can then insert any additional field codes as required. By listing all 
of the common terms in the AutoMark file, you are able to save time with each new document. 
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MARKING INDEX ENTRIES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise you 

MUST open the file W853 
Indexing_1.docx... 

 Navigate to page 3 and select 
environment in the first paragraph 

 Click on the References tab, then 

click on Mark Entry  in the 

Index group to open the Mark 
Index Entry dialog box 

 Click on [Mark All] to mark all 
occurrences of the word 
environment 

 Click on [Close] 

When marking index entries, Word 
will show all formatting codes – 
notice the index field next to the 
text… 

 Select the word Arachnids on the 
same page, then press  +  

+  to open the Mark Index Entry 

dialog box 

 Type Arachnidae in Main entry 

An index entry need not be identical 
to the text... 

 Click on [Mark All] then click on 
[Close] 

 Click on the Home tab, then click 

on Show/Hide  to hide the 

codes 

 Save and close the document 

 

For Your Reference… 

To mark an index entry: 

1. Select the text 

2. Press  +  +  

3. Type the index entry in Main entry 

4. Click on [Mark] or [Mark All] 

5. Click on [Close]  

Handy to Know… 

 If you are marking index entries for the whole 
document, you can leave the Mark Index 
Entry dialog box open while you mark each 
entry, that is, you can still select text while 
the dialog box is open. When you click in the 
dialog box, the Main entry field is updated. 

1 

2 

An index lists the topics (such as relevant key 
words and phrases) in a document, and is 
designed to make long documents easy to 
navigate. The first step in creating an index is to 

mark the words and phrases that you want to 
include in the index. This is done selecting a word 
and using the Mark Index Entry dialog box to add 
an index field to the text. 

4 
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CREATING AN AUTOMARK FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise you 

MUST open a new, blank 
document... 

 Click on the Insert tab, then click on 

Table  in the Tables group to 

display the menu 

You will create a 2-column table… 

 Hover the mouse pointer over the 
grid to highlight a table with 2 
columns and 4 rows, then click to 
insert the table 

 Ensure the cursor is positioned in the 
first cell, type environmental and 

press  

Word has automatically capitalised 
the word, but marked text is case-
sensitive, so it needs to be 
lowercase… 

 Hover over the E, then hover over 
the blue square that appears below it 

to display AutoCorrect Options  

 Click to display the menu and select 
Stop Auto-capitalising First Letter 
of Table Cells 

This will stop automatic 
capitalisation… 

 Enter the remaining entries as shown 

 Save the document as 
MyAutoMarkFile.docx in the course 
files folder, then close the document 

 

For Your Reference… 

To create an AutoMark file: 

1. Create a new, blank document 

2. Insert a table with two columns 

3. Type text to mark in the left column and 
index entries in the right column of the table 

4. Save and close the document 

Handy to Know… 

 In previous versions of Word, an AutoMark 
file was called a concordance file. 

 For an AutoMark file to work properly when 
cross-referenced with another document, the 
text in the first column must exactly match 
the document text. For instance computer is 
not the same as Computer (case-sensitive). 

 

2 

4 

To mark text for inclusion in an index, you can 
either mark it manually using the Mark Index 
Entry dialog box (as in the previous exercise), or 
you can mark text automatically by creating an 

AutoMark file. This file must be a two-column 
table, with the list of text to mark in the first column 
and the index entries in the second column. An 
AutoMark file enables you to mark text quickly. 

6 
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MARKING INDEX ENTRIES WITH AN AUTOMARK FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file W853 
Indexing_2.docx... 

 Click on the References tab, 

then click on Insert Index  

in the Index group to display 
the Index dialog box 

 Click on [AutoMark] to display 
the Open Index AutoMark 
File dialog box 

This dialog box enables you to 
locate and open the AutoMark 
file that you want to use... 

 Navigate to the course files 
folder and click on  
MyAutoMarkFile.docx 

 Click on [Open] 

Word now scans through the 
document, marking all the text 
that matches the entries in the 
AutoMark file table... 

 Scroll through the document to 
view the new entries 

Running the AutoMark file 
displays the index fields in the 
document... 

 Click on the Home tab, then 

click on Show/Hide  in the 

Paragraph group to hide the 
codes 

 

For Your Reference… 

To mark entries using an AutoMark file: 

1. Click on the References tab, then click on 

Insert Index  in the Index group 

2. Click on [AutoMark] 

3. Locate and click on the AutoMark file 

4. Click on [Open]  

Handy to Know… 

 Remain mindful of the multitude of different 
ways that people classify information. Two 
people, for example, may classify the same 
thing in different ways, such as dirt and soil. 
Try to account for and include these 
differences where possible. 

1 

5 

One distinct advantage of using an AutoMark 
file to build your index is that once it is created 
and saved, you can apply it to any document that 
you want indexed. This is useful if documents 

you create contain similar topic matter. Word uses 
the text in the left column of the AutoMark file to 
locate text to be marked in the document, then lists 
it in the index using the entry in the second column. 
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REMOVING MARKED ENTRIES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file W853 
Indexing_3.docx... 

 Click on the Home tab, then 

click on Show/Hide  in the 

Paragraph group to display 
index fields 

 Navigate to the bottom of page 
3 and position the cursor to the 
left of {XE “environment”} in 
the last paragraph 

This marked entry is not 
necessary, as environmental is 
part of the name of an 
organisation… 

 Press   

You will notice that the field is 
highlighted (selected)… 

 Press  to delete the field  

 Repeat steps 2 to 4 to delete 
{XE “habitat”} on page 6 
(Turtles) 

 Ensure the Home tab is active, 

then click on Show/Hide  

in the Paragraph group to hide 
the index fields 

 Save and close the document 

 

For Your Reference… 

To remove index entries: 

1. Click on the Home tab then click on 

Show/Hide  to display the index fields 

2. Position the insertion point to the left of the 
index field that you want to delete 

3. Press  twice 

Handy to Know… 

 If you have been indexing a document or 
checking the index marks, don’t forget to 

click on Show/Hide  to hide the fields 

before adjusting pagination, as the fields 
disrupt pagination (on-screen only) and the 
document will not print as it appears. 

 

2 

3 

Where you have used an AutoMark file to mark 
entries for indexing, you may find that you will 
need to remove marked entries from a document. 
As an AutoMark file will mark all matching 

instances of an entry, you may end up with marked 
entries that are not relevant or that you don’t want 
to include. You can remove index entries by 
selecting and deleting the relevant index fields. 

5 
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GENERATING AN INDEX 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file W853 
Indexing_4.docx... 

 Press  +  to move to the 

end of the document 

A heading for the index is 
already created – the insertion 
point should now be below the 
heading... 

 Click on the References tab, 

then click on Insert Index  

in the Index group to open the 
Index dialog box 

 Ensure Indented is selected 
for Type, then click on the 
drop arrow  for Formats and 
select Classic 

 Click on [OK] to generate the 
index 

A two-column index will be 
created from the index entry 
fields in the document… 

 Ensure the Home tab is active, 

then click on Show/Hide  

in the Paragraph group to hide 
the field codes 

 Save the document 

 

For Your Reference… 

To generate an index: 

1. Position the insertion point 

2. Click on the References tab, then click on 

Insert Index  in the Index group 

3. Make your selections 

4. Click on [OK] 

Handy to Know… 

 To delete an index, click in the index and 
then press  +  to display the index 

field. Select the index field and then press 
. 

2 

4 

Generating the index is probably the easiest part 
of the whole indexing process. Once all of the 
index entries have been marked, you then only 
need to position the cursor at the point in the 

document where you want to insert the index 
(typically near the end of the document), and then 
decide on the desired format and layout of the 
index. Word will do the rest. 
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MODIFYING THE INDEX FORMAT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file W853 
Indexing_5.docx... 

 Press  +  to move to the 

end of the document, then 
click in the index 

 Click on the References tab, 

then click on Insert Index  

in the Index group to open the 
Index dialog box 

You will make some changes 
to the format… 

 Click on the up arrow  for 
Columns to change to 3 

 Click on the drop arrow   for 
Formats and select Modern 

 Click on [OK] to apply the 
changes 

You will be asked if you want 
to replace the current index... 

 Click on [OK] 

The index will now display the 
formatting changes… 

 Save the document 

 

For Your Reference… 

To modify the index format: 

1. Click in the index 

2. Click on the References tab, then click on 

Insert Index  in the Index group 

3. Make the required changes, then click on 

[OK], then click on [OK] 

Handy to Know… 

 You don’t need to rely on the limited range of 
formatting options in the Index dialog box. 
You can apply any formatting to an index as 
you would to any other text in the document. 
However once you update the index any 
formatting will be lost. One solution is to 
modify the index styles: Index 1, Index 2 etc. 

 

2 

6 

Once you have generated your index, you may 
want to make adjustments to the formatting and 
layout of the index to meet, for example, 
document or organisational requirements. For 

instance, you might want to apply a three-column 
format, or perhaps you would prefer to apply a 
different format altogether. You can modify the 
format of an index in the Index dialog box. 
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UPDATING AN INDEX 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file W853 
Indexing_6.docx... 

 Navigate to page 2 and 
position the cursor immediately 
before the heading Frogs 

Let’s change the pagination of 
the document first... 

 Press  +  to insert a 

page break, thereby forcing 
the text to the next page 

Now let’s update the index... 

 Press  +  to move to the 

last page, then click on the 
index 

Notice that the entry for 
“frogs”, under “amphibians” is 
currently listed on page 2... 

 Click on the References tab, 
then click on Update Index 

 in the Index group 

“frogs” will now be listed on 
page 3… 

 Save and close the document 

 

For Your Reference… 

To update an index: 

1. Click on the index 

2. Click on the References tab on the ribbon 

3. Click on Update Index  in the Index 

group 

Handy to Know… 

 You can also right-click on an index and 
select Update Field to update it. 

 You can also press  to update an index. 

1 

2 

An important and time-saving aspect of indexing 
in Word is that you are able to automatically 
update the index when changes have been 
made in the document. This feature ensures that 

if you add or remove any index entries to or from 
the document, or alter the pagination, the 
modifications can then be automatically 
incorporated into the index at the click of a button. 
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NOTES: 
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