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Microsoft SharePoint 2010
8 – Creating and editing pages

Microsoft SharePoint 2010

CREATING AND EDITING PAGES
INFOCUS

All new SharePoint sites have only one page that you can
edit – the home page. And this page needs to be edited to
make it appropriate and relevant for your business needs.
As well as editing the home page, you can also create as
many new pages in your site as desired, adding content
and links to them.
In this booklet, we’re assuming that you have the default
Contribute permission levels which allow you to both edit
the home page and create new wiki pages. This default
permission level doesn’t allow you to create other types of
pages.

In this booklet you will be shown how to:


place a page in edit mode



insert and format text



insert tables



insert pictures



insert hyperlinks



insert list and library web parts



create new wiki pages



link to an existing wiki page



link to a new wiki page



delete a wiki page
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PLACING A PAGE IN EDIT MODE
The individual web pages in a SharePoint
site comprise various components, such as
the welcome text, Shared Documents web
part, stock image and the Getting Started
links on a default team site’s home page.

If you have the correct permissions, you can
edit some of these components. But before
you can do this, you must first display the
page and place it in edit mode.

Example:

1

We displayed the Home
page, then clicked on [Site
Actions] in the ribbon and
selected Edit Page
Two blue boxes will appear
on the page to show both
the editable areas and its
current text layout, and two
Editing Tools tabs will
display…

2

Then we clicked on the
Insert tab
This tab has the tools for
inserting content into a
page…

3

Then clicked on the Format
Text tab
This tab contains the tools
for formatting text, applying
styles and saving your
changes.

1
Notice that the cursor appears at the top of the page in
edit mode. Notice also that the Quick Access bar is not
editable in edit mode, only the content surrounded by the
blue boxes.
2

To switch to normal mode
without saving any
changes…

4

We clicked on the arrow
below Save & Close and
selected Stop Editing
The page will switch back to
normal mode

3

For Your Reference…

Handy to Know…

To place a page in edit mode:
1. Display the page
2. Click on [Site Actions] and select Edit Page
To close a page without saving the changes:
1. Click on the arrow below Save & Close in the
Edit group on the Format Text tab and select
Stop Editing

 You can also place a page in edit
mode by clicking on Edit
, which
is located to the left of the Browse
tab in the ribbon.
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INSERTING AND FORMATTING TEXT
You can insert text into a page by clicking
in the desired location and typing as if you
were using Word. The text will be
formatted using the default settings. You
can change this formatting by selecting the

Example:

1

text and using the formatting tools or one of
the style options to quickly apply a style.
Note that you cannot edit text in a web part
like the Shared Documents web part on
our home page.
2

We placed the Home page in
edit mode
To edit some text…

2
3

We clicked to the left of your
in the heading, then dragged
to select the text your site!

3

Next we typed the Finance
Team
To format some text now…

4

We clicked in the grey
paragraph beneath the
heading, then clicked on
Select in the Markup group
and selected Paragraph

4

This will select all text in the
paragraph…

5
6

Then we clicked on Markup
Styles to see a list of default
HTML styles that have been
defined for pages in this site
We clicked away from the
menu to close it, then clicked
on Styles to see a list of other
quick styles that you can
apply, then closed this menu
You can also use the more
typical formatting tools…

7

8

Finally we clicked on 8pt in
Font Size, typed 9pt, pressed
to increase the font size
by 1pt, then clicked away from
the text to see the result

There is a second option available under the
Select drop-down menu – Text division. If you
had selected Text division rather than Paragraph,
all of the content in the left content block (and
SharePoint has named this the Text division by
default) would have been selected rather than
just the paragraph which is what we wanted.
Notice that as you hover over a selection in the
drop-down menu, SharePoint displays a red
dashed box to show what will be selected if you
choose the option.
7

Then clicked on Save & Close

For Your Reference…

Handy to Know…

To insert and format text:
1. Display the page and place it in edit
mode
2. Click where you want to insert the text
3. Type the text
4. If desired, select the text and click on a
tool or command on the Format Text
tab

 You can change how a page is laid out
by using the Text Layout command on
the Format Text tab. From this dropdown menu, you can change the layout
to two columns (which is the layout for
a default team site’s home page), two
column with header and footer, three
columns, and more.
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INSERTING TABLES
You can insert a table into a page just like
you do in Word. And once inserted, you
can edit a table by clicking in it to display
the two contextual tabs and then selecting
the desired options. The Layout tab lets

you alter the table’s layout (inserting and
removing rows and columns, specifying row
height, etc) while the Design tab lets you
apply styles, select header rows and more.

2

Example:

1

We placed the Home page in
edit mode

2

Then we clicked between the
image and the Getting Started
information
To insert a table in this blank
paragraph…

3

3

We clicked on the Insert tab,
then clicked on Table to display
the Insert Table grid
This command operates very
similarly to Word…

4

Next we clicked on the second
square in the top row to insert a
table with one row and two
columns
You can insert text into this
table just as you do in Word.
Two Table Tools tabs will also
open which let you format the
table…

5

4

Then we clicked on the Design
tab to see the available options,
then clicked on Styles and
selected Table Style 3 –
Medium Two Tones to apply
this style
To delete it…

6

We clicked on the Layout tab,
then clicked on Delete and
selecedt Delete Table

7

Finally we clicked on Save &
Close on the Format Text tab

5

For Your Reference…

Handy to Know…

To insert a table:
1. Display the page and place it in edit
mode
2. Click where you want to insert the table
3. Click on Table on the Insert tab
4. Select the number of rows and columns
5. Format the table as desired

 If you don’t want to select the number of
columns and rows for your table by
clicking on the squares in the quick grid
option, you can click on Insert Table.
This will open a dialog box into which
you can type the required number of
columns and rows for your table.
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INSERTING PICTURES
You can insert images into a page by
clicking in the desired location and
selecting the Picture command on the
Insert tab. Once inserted, you can format
the picture using the Design tab.

For example, you can set alternate text for
the image (this text can be read by visually
impaired people using screen reader
applications), apply an image style border
and resize the image.
3

Example:

1

We placed the Home page in
edit mode
To replace the stock image
with our own…

2

We clicked on the image to
select it, then pressed
to
delete it

3

Then we clicked on the Insert
tab, then clicked on the lower
half of Picture and selected
From Computer to open the
Select Picture dialog box

4

Next we clicked on [Browse],
navigated to the course files
folder, clicked on Team
Image, and clicked on [Open]

5

By default, the image will be
uploaded to the Site Assets
library in your site…

5

Then we clicked on [OK] and
then clicked on [Save] to
insert the image into the page

6

To resize it…

6

We ensured that the image
was selected and that Lock
Aspect Ratio was ticked on
the Picture Tools: Design
tab, then selected 800 px in
Horizontal Size, typed 395
px and pressed
to resize
the image

7

Finally we clicked on Save &
Close on the Format Text tab

For Your Reference…

Handy to Know…

To insert a picture into a page:
1. Display the page and place it in edit mode
2. Click where you want to insert the picture
3. Click on Picture on the Insert tab
4. Browse to the image and click on [Open]
5. Format the picture as desired

 Rather than deleting the picture and
inserting a new one, you could have
changed it. To do this, click on the image,
click on the lower half of Change Picture
and select From Computer, browse to the
folder, click on the image, click on [Open]
and then click on [Save].
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INSERTING LINKS
If you have internet sites that your users
regularly visit, such as suppliers or clients,
you can insert hyperlinks into a page that,
when clicked, will open their sites in the
browser. You can either insert new text or

Example:

1

We placed the Home page in
edit mode, then clicked in the
blank area between the
Welcome text and the Shared
Documents web part

2

Then we clicked on the Insert
tab, then clicked on Link to
open the Insert Hyperlink
dialog box
To insert a link to a well-known
search engine (as an
example)…

3

We typed Search the
Internet in Text to display

4

Then typed
dhttp://www.google.com/
in Address, then clicked on
[OK] to insert the link and
open the Link Tools: Format
tab

5

select existing text for the hyperlink. After
inserting a link, you can modify its properties
by clicking on the link and opening the Link
Tools: Format tab.
1

2

4

Next we typed Google in
Description, then clicked on
Open in new tab in the
Behaviour group
The Description will appear
when you hover over the link…

6

Then clicked on Save & Close
on the Format Text tab
To test the link…

7

We clicked on Search the
Internet
Google will open in a new
window or tab…

8

Close the new browser window
or tab to return to SharePoint

5

For Your Reference…

Handy to Know…

To insert a link into a page:
1. Display the page and place it in edit mode
2. Select the text for the link or click in the page
3. Click on Link on the Insert tab
4. Type the text and address then click on [OK]
5. Format the link as desired

 As soon as you place a page in edit mode,
the Edit tool
(which is located to the left
of the Browse tab in the ribbon) is replaced
by the Save & Close tool
. You will find
that it is often quicker to use this tool rather
than clicking on Save & Close on the
Format Text tab and when you’re finished.
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INSERTING LIST AND LIBRARY WEB PARTS
A web part is a server control that serves a
particular purpose, such as the Shared
Documents web part on the home page
that displays the data in this document

library. Users with the default contribute
permissions can insert only a few web parts,
but you can insert web parts for all lists and
libraries that exist in your site.

1

Example:

1

We placed the Home page in edit
mode, then clicked in the blank
area beneath the image

2

Then we clicked on the Insert tab,
and clicked on Web Part to open
the Web Parts panel across the
top of the page
This panel shows all web parts
grouped into categories…

3

3

We ensured that Lists and
Libraries is selected under
Categories, then click on
Announcements under Web
Parts and click on [Add]
The Announcements web part
inserted into the page, ready for
you to insert new items…

4

Next we clicked to the right of the
Announcements title to select the
web part and open the Web Part
Tools: Options tab, then clicked
on the Options tab to see the
available options

5

We clicked on Minimise, then
clicked on Save & Close
in the
ribbon

5

To restore the web part again…

6

We clicked on Edit
, clicked on
the blue line under
Announcements to select the web
part, then clicked on Restore on
the Options tab

7

Finally we clicked on Save & Close

For Your Reference…

Handy to Know…

To insert a list or library web part:
1. Display the page and place it in edit
mode
2. Click where you want to insert the web
part
3. Click on Web Part on the Insert tab
4. Click on the desired web part, then
click on [Add]

 Because we were inserting a web part for a
list or library in this exercise, we could have
also clicked on Existing List on the Insert
tab at step 2. The Existing List option
shows only the web parts that belong to the
Lists and Libraries category in the dialog
box rather than showing all categories.
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CREATING A NEW WIKI PAGE
Wiki pages are very simple web pages into
which you can insert content such as text,
images, videos, hyperlinks and more.
When you create a wiki page, you may be
prompted to create two new libraries for

Example:

1

the site if they don’t already exist: Site
Pages (for the wiki pages) and Site Assets
(for any images and other files – these are
known as assets – that you upload into the
page).
1

We clicked on [Site Actions]
and selected New Page to
open the New Page dialog box
It’s important to name the file
carefully – make it short but
meaningful. This name
becomes both the file’s name
(used in the URL) and title
(appears in the breadcrumb)…

2

Then typed Accounts
Receivable in New page
name, then clicked on
[Create]

2

The new wiki page will open in
edit mode ready for you to add
content into the blue box…

3

We typed Accounts
Receivable Team, then
selected the text, clicked on
Markup Styles and selected
Heading 1 to apply this style.
We clicked away from the text
to see the result

4

Next we clicked on the Insert
tab to see that we can insert
the same type of content just
as we could when we edited
the Home page

5

Finally we clicked on Save &
Close
to save the page

3

The page is called Accounts
Receivable in the breadcrumb
trail…

For Your Reference…

Handy to Know…

To create a new wiki page:
1. Click on [Site Actions] and select New
Page
2. Type a page name
3. Click on [Create]
4. Edit the page as desired

 You can rename a wiki page if necessary. To do this,
open the page by clicking on its link in the Site
Pages document library (on the All Site Content
page). Switch to edit mode, then click on Rename
Page on the Page tab. Note, however, if you
rename a page, you will break any links that point to
this page.
 permission other types of pages
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LINKING TO AN EXISTING WIKI PAGE
Wiki syntax lets you create links to existing
pages on the fly. You can display a pop-up
menu listing all pages in the site by typing
[[. After selecting the page and typing ]],
the page’s name will be automatically
1

Example:

1

We placed the Home page in edit
mode, then clicked in a blank area
below the Shared Documents
web part
To add some text and link it to the
wiki page that we created …

2

We typed For extra team
information: then pressed
create a new paragraph

3

Then we clicked on Bullets
in
the Paragraph group to convert
this paragraph to a bullet list item,
then typed [[

2

to

3

A pop-up menu will appear
displaying the pages in the site. If
the menu doesn’t appear, press
+
…

4

We clicked on Accounts
Receivable and typed ]] to
complete the link
The page’s name will display as the
link text…

5

converted to a link. You can’t change this
link text so it’s important that wiki pages are
named appropriately when they’re created
(which is why we included a space in our
wiki page name).

4

Then clicked on Save & Close
to save the page
The link will be purple indicating
that it links to an existing page. To
test it…

6

We clicked on the Accounts
Receivable link to display the
Accounts Receivable wiki page,
then navigated back to the Home
page

5

For Your Reference…

Handy to Know…

To create a link to an existing page:
1. Display the page and place it in edit
mode
2. Click where you want to insert the link
3. Type [[
4. Select the desired page and type ]]

 You can link existing text to a page. To do
this, select the text to be linked, then click
on Link on the Insert tab. The selected
text will appear in Display. Type the URL to
the wiki page in Address – for example:
/sites/london/train1/
sitepages/accounts receivable.aspx.
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LINKING TO A NEW WIKI PAGE
If you want to link text to a page that
doesn’t exist, you don’t need to stop and
create the page first. Using wiki syntax,
you can type the text that you want to be
converted to a link inside double square

Example:

1

We placed the Home page in
edit mode, then clicked at the
end of the [[Accounts
Receivable]] link and
pressed

2

We typed [[Accounts
Payable]]
As you are typing, a message
will appear informing you that
the item doesn’t exist…

3

2

3

Then we clicked on Save &
Close
The link will be blue with a
black dotted underline. To
create the page…

4

We clicked on the Accounts
Payable link to open the
New Page dialog box

5

Then clicked on [Create] to
create the Accounts
Payable page and open it in
edit mode

6

Next we typed Accounts
Payable, then selected the
text, clicked on Markup
Styles and selecedt Heading
1 to apply this style. We
clicked away from the text to
see the result

7

brackets and it will be saved as a link. The
link will appear with a black dotted underline
showing that the page doesn’t exist. Clicking
on this link will then let you create the new
page.

6

7

Finally we clicked on Save &
Close
, then navigated to
the Home page
The link is purple now
showing that the linked page
exists

For Your Reference…

Handy to Know…

To link to a new page:
1. Display the page and place it in edit
mode
2. Click where you want to insert the link
3. Type [[new page name]], then click
on Save & Close
4. Click on the new link and click on
[Create] to create the new page

 If you don’t have time or the
information to create all pages to which
you have linked, other people can
come along at a later date and create
the pages for you. The dotted
underlines and blue colouring clearly
highlight links to non-existent pages.
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DELETING A WIKI PAGE
Because it’s so easy to create and populate
wiki pages, if you add a lot of content to a
page and then decide that it needs a lot of
editing, you may find that it’s actually
quicker and easier to delete the page and

Example:

1

start again. Wiki pages are usually stored in
the Sites Pages document library so to
delete an unwanted page, you simply select
it in this library and click on Delete
Document.

3

We selected Site Actions
> New Page to open the
New Page dialog box,
typed Test in New page
name and clicked on
[Create]
To see how easy it is to
delete an unwanted page…

2

We clicked on All Site
Content in the Quick
Launch bar to opened the
All Site Content page

3

Then we clicked on Site
Pages under Document
Library to display all
pages stored in this library

5

The Test, Accounts Payable
and Accounts Receivable
pages are listed, as well as
two other pages…

4

We hovered over Test,
then clicked on its check
box to select the page and
opened the Documents
tab

5

Then clicked on Delete
Document in the Manage
group – a message box will
display

6

Finally we clicked on [OK]
to delete the page

6

For Your Reference…

Handy to Know…

To delete a wiki page:
1. Click on All Site Content in the Quick
Launch bar, then click on Site Pages
2. Select the desired page
3. Click on Delete Document in the
Manage group on the Documents tab,
then click on [OK]

 If you have existing links to a
deleted page, the linked text will
change from purple to blue with a
black dotted underline.
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CONCLUDING REMARKS

Congratulations!
You have now completed the Creating and editing pages booklet. This booklet was
designed to get you to the point where you can competently perform a variety of
operations as listed in the objectives on page 2.
We have tried to build up your skills and knowledge by having you work through specific
tasks. The step by step approach will serve as a reference for you when you need to repeat
a task.

Where To From Here…
The following is a little advice about what to do next:
 Spend some time playing with what you have learnt. You should reinforce the skills
that you have acquired and use some of the application's commands. This will test
just how much of the concepts and features have stuck! Don't try a big task just yet if
you can avoid it - small is a good way to start.
 Some aspects of the course may now be a little vague. Go over some of the points
that you may be unclear about. Use the examples and exercises in these notes and
have another go - these step-by-step notes were designed to help you in the
classroom and in the work place!
Here are a few techniques and strategies that we've found handy for learning more about
technology:


visit CLD’s e-learning zone on the Intranet



read computer magazines - there are often useful articles about specific techniques



if you have the skills and facilities, browse the Internet, specifically the technical
pages of the application that you have just learnt



take an interest in what your work colleagues have done and how they did it - we
don't suggest that you plagiarise but you can certainly learn from the techniques of
others



if your software came with a manual (which is rare nowadays) spend a bit of time
each day reading a few pages. Then try the techniques out straight away - over a
period of time you'll learn a lot this way




and of course, there are also more courses and booklets for you to work through
finally, don’t forget to contact CLD’s IT Training Helpdesk on 01243-752100
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