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MANAGING DOCUMENTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Content managers or authors are responsible for getting 

information into SharePoint and then working with it. In 

this chapter you’ll learn how to upload files into document 

libraries, create new documents from within SharePoint, 

edit documents, delete documents, and more.  

In this booklet you will be shown how to: 

 upload files into SharePoint 

 upload multiple files simultaneously 

 upload files from an Office application 

 upload files using the Web Folders interface 

 understand co-authoring Word documents 

 compare versions of a Word document 

 create a new folder in a document library 

 use SharePoint Workspace 

INFOCUS 
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UPLOADING A FILE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For Your Reference… 

To upload files into SharePoint:  

1. Open the document library in 

SharePoint, then open the folder (if 

necessary) 

2. Click on Add document 

3. Click on [Browse] then navigate to 

the folder 
4. Click on the file then click on [Open] 

Handy to Know… 

 You need to use a slightly different 

method for uploading pictures into a 

Picture library as Picture libraries don’t 

have the ribbon. Instead, click on 

Upload in the toolbar at the top of the 

library and select Upload Picture. This 

opens the same dialog box as 
described above. 

4 

2 

There are three main methods for 

uploading files into document libraries. In 

this example we show how to upload a file 

into the Shared Documents library from 

within SharePoint. Using either the Upload 

Document tool on the Documents tab or 

the Add document link in the library, you 

can browse to the file. This method is ideal 

for uploading any file types, including non-
Office files such as PDFs. 

5 

Example: 

1 We clicked on Shared 

Documents to open this library  

2 Then we clicked on the Add 

document link in the library to 

open the Upload Document 

dialog box 

Note that the blue Upload 

Multiple Files link only appears 

in this dialog box if you’re using 

Internet Explorer… 

3 Then clicked on [Browse] to 

open the Choose File to 

Upload dialog box, and 

navigated to the course files 

folder 

4 Next we clicked on 

Environmental Health and 

Safety Policy, clicked on 

[Open], then clicked on [OK] 

to upload the file 

Depending on how your library 

is set up, you may be prompted 

to check the file’s properties. 

Properties with a red asterisk 

are mandatory… 

5 If prompted, check the 

properties (note that the Info 

bar says that you have to check 

in the file to make it accessible 

to others) and click on [Save] 

to automatically check in the 

uploaded file 
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UPLOADING MULTIPLE FILES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For Your Reference… 

To upload multiple files: 

1. Open the document library 

2. Click on the bottom of Upload 

Document in the New group on the 

Documents tab and select Upload 

Multiple Documents 

3. Open Windows Explorer, drag and drop 

the files and click on [OK] 

Handy to Know… 

 You can upload multiple documents from 

the Upload Document dialog box. To do 

this, click on Add document in the library 

then click on the Upload Multiple Files 

link in the Upload Document dialog box. 

The Upload Multiple Files link will only 

appear if you are able to upload multiple 
documents. 

You can upload multiple files 

simultaneously if you are using Internet 

Explorer and if you have the appropriate 

Microsoft Office components installed on 

your computer. To check whether or not 

you’re able to perform this function, click on 

the bottom half of Upload Document on 

the ribbon – if Upload Multiple 

Documents is unavailable, you will need to 
upload them individually. 

3 

4 

Example: 

1 We clicked on the Documents tab 

in the Shared Documents library 

2 Then clicked on the bottom of 

Upload Document in the New 

group to display a drop-down menu 

3 Next we clicked on Upload 

Multiple Documents (if available) 

to open the Upload Multiple 

Documents dialog box 

You can either drag and drop or 

browse for the files… 

4 Then we opened Windows 

Explorer in a small window, 

navigated to the course files folder, 

selected the four files (Internet 

And Email Policy, Invoice Silver 

Pen, No Smoking Policy and 

Quarterly Report Indoor Oasis), 

dragged them into the blue box as 

shown, then release the mouse 

button to add the files 

5 Next we closed Explorer, then 

clicked on [OK] and on [Done] to 

upload the files 

Files uploaded like this are not 

automatically checked in… 

6 Finally we selected the four new 

files by clicking on their check 

boxes, then clicked on Check In in 

the Open & Check Out group, 

then clicked on [OK] to check 

them in as minor versions 
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UPLOADING A FILE FROM AN OFFICE APPLICATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For Your Reference… 

To upload files from an Office 

application: 

1. Open the file in the Office application 

2. Select File > Save & Send > Save 

to SharePoint 

3. Browse for a location if necessary 

4. Click on [Save As] then click on 
[Save] 

Handy to Know… 

 You can store a presentation as individual 

slides by uploading it into a Slide library 

(if you have SharePoint Server). During the 

upload, you select the specific slides to 

publish to the library. To re-use them in a 

new presentation, select the desired slides 

and click on [Copy Slide to 
Presentation]. 

1 

3 

SharePoint 2010 and Office 2010 

applications are closely integrated. And 

one of the ways that they work together is 

that you can open a file in an Office 

application, such as a document in Word or 

a presentation in PowerPoint (which we show 

in this example) and save the file into a 

SharePoint document library directly from 
the Backstage of the Office application. 

6 

Example: 

1 We clicked on the File tab, 

clicked on Save & Send and 

then clicked on Save to 

SharePoint 

2 Then we double-clicked on 

Browse for a location under 

Locations to open the Save 

As dialog box 

3 Next we selected the path in 

the path box at the top left of 

the dialog box, then typed the 

path to the site and pressed 
  

E.g. our path to the All Site 

Content page is 

http://company 

web/sites/london/train1… 

4 We double-clicked on Shared 

Documents under Document 

Libraries, then clicked on 

[Save] to upload the file into 

SharePoint 

The Info Bar in PowerPoint will 

change to let you check in the 

file… 

5 Next we clicked on [Check In] 

in the Info Bar, clicked on 1.0 

Major version, and then 

clicked on [OK] to check in the 

file 

6 Finally we closed PowerPoint, 
then pressed  and clicked on 

[Retry] (if prompted) to 

refresh the Shared 

Documents library 
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UPLOADING FILES USING WEB FOLDERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For Your Reference… 

To upload files using web folders: 

1. Open the document library 

2. Click on Open with Explorer in the 

Connect & Export group on the 

Library tab 

3. Navigate to the folder and copy the 

files 

4. Click on Back  and press  +  

Handy to Know… 

 Uploading files using this method doesn’t let 

you update the files’ properties. Instead, 

you will need to edit their properties if 

necessary (see Editing A List Item later in 
this chapter). 

 You can also use the web folders interface 

to delete files and folders as needed. To do 

this, select them and press . 

2 

The web folders interface allows you to 

look at your SharePoint site as though it 

were a series of folders on a network drive. 

When activated, the web folders interface 

opens in a Windows Explorer window. 

Using this interface, you can quickly copy 

any number of files from your desktop or 

other folder and paste them into a document 
library in SharePoint. 

5 

Tip: When files are checked out, their Type icon 

appears with a green downwards pointing arrow in 

the library. For example,  

Example: 

1 We ensured that the Shared 

Documents library is open, 

then clicked on the Library tab 

2 We clicked on Open with 

Explorer in the Connect & 

Export group to open the 

Shared Documents library as a 

web folder 

3 Next we navigated to the 

Course Files for SharePoint 

2010 folder 

Let’s copy a file from this folder 

into SharePoint… 

4 We clicked on Sales Figures 

Silver Pen.xlsx, then pressed 

 +  to copy this file to the 

clipboard 

5 Then clicked on Back to Shared 

Documents  in the top left 

corner of the web folders 

window and pressed  +  to 

paste a copy of the file into the 

Shared Documents library 

6 Then closed the web folder 
window, then pressed  and 

clicked on [Retry] (if prompted) 

to refresh the Shared 

Documents library 

Again you will need to manually 

check in this file… 

7 Finally we selected the new file, 

clicked on Check In in the 

Open & Check Out group, 

clicked on 1.0 Major version 

and clicked on [OK] 
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CO-AUTHORING WORD DOCUMENTS 
 

 

 

 

 

 

New to SharePoint 2010, multiple people 

can edit the one document in Word at the 

same time. If someone else is editing the 

file that you open, a message will display 

telling you who is editing it and the 

paragraph that the other person is working 

on will be highlighted. You cannot edit the 

highlighted paragraph until the document is 
saved and uploaded to the server.  

Let’s assume another user has already selected the Internet And Email Policy in the 

Shared Documents library and has clicked on Edit Document on the Documents tab to 

edit it in Microsoft Word. If you were to then select the same document and choose to edit it 
in Word, the following message and details would appear, as shown below to the right. 

The area in the document that is currently 

being worked on by another user is 

highlighted with a blue vertical line. The 

user’s name is also linked to this line. You 

can edit all areas of the document except 

for the areas being worked on by other 

users.  

For example, here to the right we have 

attempted to delete the word department 

in the paragraph currently being edited by 

Peter Morrow. Word hasn’t allowed our edit 

as you can see by the message in the 

status bar. 

It’s important to note that when multiple 

users are working on the same document 

that you are, make sure you save your 

document regularly as this will refresh your 

document from the server, highlighting any 

changes made by the other user. 

If you want to contact one of the other 

users currently working on the document, 

hover over the name to the left of a 

highlighted paragraph and select the 

appropriate contact icon from the box with 

their name and email address details, such 

as Send an e-mail message. 

Alternatively, you can click on [Send a 

Message] from the Info tab of the 

backstage. 

Note: Co-authoring will not work if the 

document library is set to require check-out 

but it will work if versioning is turned on. 

 

The number of users currently working 

on the document is displayed in a tool 

with a number (2 in our case) in the 

status bar, and clicking on this tool will 

display the names of the users working 

on the document, as shown below. 
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COMPARING VERSIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For Your Reference… 

To compare versions of a document: 

1. Open the library, then click on the 

Name of the file 

2. Click on Check Out and Edit, then 

click on [OK] 

3. Click on Compare on the Review tab, 

then select the desired option  

Handy to Know… 

 While editing a Word document, you 

can compare it with the latest version 

of the file that is saved on the 

SharePoint server. To do this, click on 

Compare and select Last Version. 

From this menu you can also combine 

the edits from different authors into the 
one version by selecting Combine. 

2 

SharePoint displays the version history of a 

selected document, as you’ve seen earlier 

in this course, but it doesn’t allow you to 

see what the actual differences between 

the versions are. But there’s a workaround 

with Word documents. By opening a Word 

document from SharePoint, you can use 

Word’s Compare feature to see the 

differences between various versions of the 
file. 

3 

Example: 

1 We opened the Shared 

Documents library, then clicked 

on the No Smoking Policy 

Name link 

2 Then we clicked on Check Out 

and Edit, then clicked on [OK] 

to open the file in Word 

3 We clicked on the Review tab, 

then clicked on Compare to 

display a drop-down menu 

Let’s compare this file (version 

1.1) with the last published (or 

major) version (1.0)…  

4 Next we selected Major 

Version 

5 Finally we closed the new 

document without saving it, 

then clicked on the File tab and 

clicked on [Discard Check 

Out] and then clicked on [Yes] 

to discard the check out.  
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For Your Reference… 

To create a new folder in a document 

library: 

1. Open the library  

2. Click on New Folder in the New group 

on the Documents tab 
3. Type the Name and click on [Save] 

Handy to Know… 

 If the document library has been 

configured to disallow folders from 

being created, the New Folder tool 
will not be available on the ribbon. 

2 

3 

Thus far, we have shown how to work with 

files at the root-level of the Shared 

Documents library. But in the real world, 

document libraries are likely to store huge 

numbers of files. To help organise a 

document library and its content, you can 

create folders and open them prior to 

uploading files. You can also create folders 
within folders as necessary. 

4 

7 

Example: 

1 We opened the Shared 

Documents library, then 

clicked on the Documents 

tab 

2 We then clicked on New 

Folder in the New group to 

open the New Folder dialog 

box 

3 Next we typed Indoor 

Oasis in Name, then 

clicked on [Save] to add 

the folder 

4 Then clicked on Indoor 

Oasis to open the Indoor 

Oasis folder 

Let’s upload some content… 

5 We clicked on the top half of 

Upload Document to open 

the Upload Documents 

dialog box 

6 Then clicked on [Browse], 

navigated to the course files 

folder, clicked on Quarterly 

Report Indoor Oasis, 

clicked on [Open], then 

clicked on [OK] 

7 Next we clicked on Check 

In to upload the file 
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For Your Reference… 

To use SharePoint Workspace: 

1. Open the site to be synchronised 

2. Select Site Actions > Sync to 

SharePoint Workspace 

3. Click on the desired list or library under 

Available on Server, then click on 

Connect to Server 

Handy to Know… 

 The first time when you use the Sync to 

SharePoint Workspace feature, you will 

be asked to create an account as the first 

step for creating a SharePoint workspace on 

your PC. From then on, SharePoint 

Workspace will use your Windows logon 

details so that you don’t need to log on to it 

separately. 

 

6 

3 

Using SharePoint Workspace, you can 

create a synchronised copy of list and 

library content on your computer. This 

means that you can access and edit files 

and list items anytime on your computer, 

even when you’re disconnected from the 

SharePoint server. And when you’re back 

online, SharePoint will synchronise the files – 

in both directions – between the server and 
your computer. 

5 

When you’re working on SharePoint Workspace 

and your computer is connected to the 

SharePoint server, synchronisation will occur 

automatically at a regular interval. But to force 

synchronisation, click on the top half of the Sync 

tool on the Sync tab. 

If you want to disconnect a list or library from 

the server, select it in the left pane and then 

click on Change Sync Settings on the Sync tab 

and click on Disconnect from Server. 

Example: 

1 We opened Shared Documents, 

then clicked on the Library tab 

2 Next we clicked on Sync to 

SharePoint Workspace – a 

message box will display  

3 Then clicked on [OK] then on 

[Open Workspace] when 100% 

appears in the green bar of the 

message box 

The Shared Documents library will 

open in the right pane of the 

Workspace. To add a file… 

4 We clicked on New Document to 

open Word, then clicked on Save 

 in the Quick Access toolbar to 

open the Save As dialog box 

5 Then typed Test in File name, 

clicked on [Save], then closed 

Word  

The items listed below Available on 

Server in the left pane are not 

synced to the workspace. To sync 

the Tasks list… 

6 We clicked on Tasks in the left 

pane, then clicked on Connect 

“Tasks” to Server to sync the 

tasks 

To edit a task on your computer, 

simply double-click on it to open 

it… 

7 Finally we closed SharePoint 

Workspace to return to SharePoint 

– the new document will be in the 

Shared Documents library.  
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Congratulations!  

You have now completed the Managing documents booklet.  This booklet was designed 

to get you to the point where you can competently perform a variety of operations as listed 

in the objectives on page 2.  

We have tried to build up your skills and knowledge by showing you specific tasks. The step 

by step approach will serve as a reference for you when you need to repeat a task. 

 

Where To From Here… 

The following is a little advice about what to do next: 

 Spend some time playing with what you have learnt. You should reinforce the skills 

that you have acquired and use some of the application's commands. This will test 

just how much of the concepts and features have stuck! Don't try a big task just yet if 

you can avoid it - small is a good way to start. 

 Some aspects of the course may now be a little vague. Go over some of the points 

that you may be unclear about. Use the examples and exercises in these notes and 

have another go - these step-by-step notes were designed to help you in the 

classroom and in the work place! 

Here are a few techniques and strategies that we've found handy for learning more about 

technology: 

 visit CLD’s e-learning zone on the Intranet  

 read computer magazines - there are often useful articles about specific techniques 

 if you have the skills and facilities, browse the Internet, specifically the technical 

pages of the application that you have just learnt 

 take an interest in what your work colleagues have done and how they did it - we 

don't suggest that you plagiarise but you can certainly learn from the techniques of 

others 

 if your software came with a manual (which is rare nowadays) spend a bit of time 

each day reading a few pages. Then try the techniques out straight away - over a 

period of time you'll learn a lot this way 

 and of course, there are also more courses and booklets for you to work through 

 finally, don’t forget to contact CLD’s IT Training Helpdesk on 01243-752100 


