
Microsoft Project 2010 - Module 1 

© Watsonia Publishing Page 127 Costs 

CHAPTER 11 COSTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Money is one of the primary elements of a project that must be kept 
under strict control. 

Microsoft Project can assist you in planning, forecasting and 
tracking costs associated with a project. 

Most costs accumulated in a project are generated through the 
variable use of resources, although there are also fixed costs and 
special one-off costs such as permits, travel, and the like. 

In this session you will: 

 gain an understanding of costs in Microsoft Project 

 learn how to review the current cost status of a project 

 learn how to assign variable costs to resources 

 gain an understanding of how variable costs are 
assigned to many resources 

 learn how to assign daily costs to resources 

 learn how to assign per usage costs to resources 

 learn how to assign fixed costs to tasks 

 learn how to assign costs to materials 

 learn how to create multiple cost tables for a resource 

 learn how to apply a different cost rate table 

 learn how to assign changing cost rates 

 learn how to assign a Cost Resource to a task 

 learn how to view the overall project costs. 

INFOCUS 
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Microsoft Project 2010 - Module 1 

© Watsonia Publishing Page 128 Costs 

UNDERSTANDING PROJECT COSTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Microsoft Project can perform some very 
elaborate and sophisticated cost analyses on 
your projects. The tools and features in Microsoft 
Project will allow you to create an overall project 

budget and to track actual expenses with relative 
ease. Microsoft Project allows you to create 
variable costs, fixed costs and cost-per-use 
costs. 

Variable Resource Costs 

The most common type of costing in Microsoft Project is the variable costing assigned to a resource. 
This is usually the hourly standard and overtime rates for labour, or an hourly standard rate assigned 
to machinery usage. The way this works in Microsoft Project is a bit like a spreadsheet – you enter 
an hourly rate into a resource sheet and Microsoft Project will apply that rate to all areas where the 
resource has been assigned to calculate a total costing for you. 

A nice feature with variable costs is that you can tell Microsoft Project when to accrue these variable 
costs. Variable costs can be accrued at the beginning or end of a task, or prorated as the task is 
underway. The table below explains the differences. 
 

Accrual Type Usage 

Beginning All costs are accrued at the start of the task. This is used when an up front payment 
is required before work commences 

Prorata Costs are accrued according to the amount of work that has been performed. If 50% 
of the work is completed then 50% of the costs will be shown 

End All costs are accrued at the end of the task. This is used in situations where you 
might be invoiced for the services of a contractor – the invoice is generally raised at 
the completion of the work. 

A slight variation on these variable costs is a per usage cost. Let’s say you need to hire a thing-a-
me-bob to dig holes. The hire company may charge you on an hourly basis and this would be the 
variable costing. However, they may charge you an administration fee each time you hire the 
equipment. In Microsoft Project you would enter this administration cost into the cost-per-use field 
for the resource. 

Fixed Costs 

Microsoft Project allows you to assign a fixed cost against a task. For example, you may have 
negotiated some contract work at a fixed price for your project. In our case study, Scott Harris, the 
project manager, has negotiated for the foundations to be poured by a concrete company. He pays a 
fixed contract price for everything to do with this task – materials, labour, equipment, and the like. 

The Cost Resource 

In Microsoft Project there is also a cost resource. This may sound a little confusing. Generally, 
costs are associated with a resource – an hourly rate for labour or a cost-per-use for machinery. But 
there are some costs, such as those associated with travel, or training, or permits, or even a party 
that may not be appropriate to link to a particular resource. Microsoft Project provides you with a 
cost resource for these situations – in our case study we have created two of them: one for building 
permits and the other for our end-of-project party. You ever only enter a cost value for these at the 
time they are assigned to a task. 

Happy, happy, happy Project Managers 

What is nice about Microsoft Project is that you can mix and match all of these cost elements within 
your project and you can check the status of the costing at any time. You may, for example, have 
tasks that have variable cost labour, cost-per-use equipment, and some fixed cost contractual 
components. When you enter all of these elements Microsoft Project will calculate a total cost for the 
task and extrapolate that up into the total cost of the summary tasks and then ultimately up into the 
total project level. 
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REVIEWING CURRENT COSTS 
 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this 
exercise you MUST open 
the file J410 
Costs_1.mpp... 

 Click on the Project tab 
on the Ribbon and click 
on Project Information 

 Click on [Statistics] to 
display the Project 
Statistics dialog box 
which shows total project 
costs 

There probably won’t be 
too many costs here just 
yet! 

 Click on [Close] 

 

For Your Reference… 

To display total project costs: 

1. Click on the Project tab on the Ribbon and 
click on Project Information 

2. Click on [Statistics] to display the Project 

Statistics dialog box 

Handy to Know… 

 It is a good idea to regularly display the 
Project Statistics dialog box as you enter 
costs just to ensure things are progressing 
as they should. 

 

1 

2 

In this session you will be working with the costs 
for The Rostadium project. The project file you 
will open has appropriate calendars and project 
summary information, tasks, durations and 

milestones, resources and resource assignments. 
But it doesn't yet have any cost data. The best way 
to check the cost status of a project is to use the 
Project Statistics dialog box. 
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ENTERING VARIABLE COSTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file J410 Costs_1.mpp... 

 Click on the View tab on the 
Ribbon and click on 
Resource Sheet in the 
Resource Views group 

 Click on $0.00/hr in Std. Rate 
for Architect 

 Type 160 and press  to 

jump to Ovt. Rate. Type 160 

and press  twice to jump to 

Accrue At 

 Click on the drop arrow  that 
has appeared and click on 
End 

The Architect will invoice us 
when his work is done... 

 Click on $0.00/hr in Std. Rate 
for Draftsperson 

 Type 48000/y and press  to 

jump to Ovt. Rate. Type 

57000/y and press  to 

complete the entry 

 Click on the Project tab, click 
on Project Information and 
click on [Statistics] 

 Click on [Close] 

 Repeat steps 2 to 6 to enter 
the information shown on the 
following page 

 

For Your Reference… 

To assign variable costs to resources: 

1. Display a Resource Sheet view 

2. Type a variable cost rate in Std. Rate and 

Ovt. Rate 

Handy to Know… 

 Always enter an amount for overtime. In 
some cases, such as salaried professionals 
who do not get paid overtime, you may be 
inclined to leave the field blank. If you then 
assign overtime, they will be charged at zero. 
The overtime hours should be charged at 
cost as an absolute minimum. 

 

7 

6 

In a project, most of your costs come from the 
resources that are carrying out the tasks. 
Typically this will be either labour or machinery 
which is costed on an hourly basis. The costs are 

calculated by the duration of the task, or the 
working hours of the resource multiplied by the 
amount entered in the Std Rate and the Ovt Rate 
in the Resource Sheet. 

3 
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CASE STUDY VARIABLE COSTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Most larger projects will require you to enter quite 
a deal of information about the variable costs for 
the resources. In our case we have about 30 
resources, many of which will require variable 

rates for both Std. and Ovt. to be entered. This is 
part of the hard slog associated with setting up a 
project. There aren’t any real tricks or traps here so 
enter the amounts shown below. 

Resource Name Std. Rate Ovt. Rate 

Building Clerk 42000/y 63000/y 

Supervisor 45000/y 67500/y 

Rigger 18.95 28.43 

Boilermaker 20.66 30.99 

Welder 20.25 30.38 

Carpenter 21.50 32.25 

Painter 12.90 19.35 

Labourer 15.50 23.25 

Driver 17.56 26.34 

On The Hammer 65.25 97.88 

Listen Ear Audio 116.80 116.80 

In Focus Video 178.00 178.00 

Pure Grass Turf 195.00 195.00 

Plumber 22.65 33.98 

Electrician 21.56 32.34 

 

Large amounts, such as 42000, 
are annual salaries. That is why 
they are entered with a /y after 
them to indicate that this is an 
annual amount. Microsoft Project 
will convert this amount into an 
hourly basis for calculation 
purposes. 

Note that in order to provide a bit 
more “realism” the list of 
resources at the left here isn’t 
the same as the order of 
resources in the project file! 
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ASSIGNING DAILY COSTS 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this 
exercise you MUST 
open the file J410 
Costs_2.mpp... 

 Click on $0.00/hr in Std. 
Rate for the High Jib 
Crane 

 Type 2700/d and press 

 

Since we pay a daily 
hire cost there is no 
need to enter an 
overtime amount. If the 
equipment is used in 
overtime hours, there is 
no additional charge to 
us… 

 Repeat steps 1 and 2 
and add a daily rate for 
the following: 

Grader 1565/d 
Air Compressor 1280/d 
Utility 215/d 

 Click on the Project tab, 
click on Project 
Information and click 
on [Statistics] 

 Click on [Close] to close 
the dialog box and 
return to the project 

 

For Your Reference… 

To assign a daily cost: 

1. Display a Resource Sheet view 

2. Type the daily cost (/d to make it a daily rate) 
in Std. Rate for the desired resource 

3. Repeat step 2 for Ovt. Rate 

4. Press    

Handy to Know… 

 You should be careful also when it comes to 
allocating the accrual method. If you have to 
pay for the resource in advance you should 
change accrual to Beginning. If you pay on 
invoice at the end of the usage you should 
change the accrual to End. In our case study 
we will leave accrual as prorata. 

 

4 

2 

A number of projects involve the hire of 
equipment, which is charged out on a daily basis. 
You can enter these types of charges into 
Microsoft Project in much the same way as you 

enter the salaries for labour. To enter a daily 
charge for an item simply type the rate followed by 
/d. When you do this Microsoft Project will still 
internally convert the rate to an hourly rate. 

3 
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ASSIGNING PER USAGE COSTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file J410 Costs_3.mpp... 

 Double click on High Jib 
Crane to display the 
Resource Information dialog 
box 

 Click on the Costs tab to 
display the Costs information 

In our case study the hire 
equipment incurs a daily hire 
charge. It also incurs an 
additional expense to cover 
insurance and administration. 
This is charged to us on a 
cost-per-use basis. It doesn't 
matter whether we hire the 
equipment for a day or for a 
year we only incur the 
additional expense once… 

 Type 1200 in Per Use Cost, 

then press  

 Click on [OK] 

 Repeat steps 1 to 4 for the 
resources as shown 

Let's see what this has done to 
the costs... 

 Click on the Project tab, click 
on Project Information and 
click on [Statistics] 

 Click on [Close]  

 

For Your Reference… 

To assign one time usage costs: 

1. Double click on the resource, then click on 
the Costs tab 

2. Type the one-time usage cost in Per Use 
Cost 

3. Click on [OK]  

Handy to Know… 

 You can have the Cost Per Use charge on 
its own. You can also have it in combination 
with the Std. Rate and Ovt. Rate, as would 
be the case where a call-out fee and an 
hourly rate is charged for service calls. 

 Use Resource Usage view to see how and 
where specifically a resource is used. 

5 

3 

Some resources are charged on a cost-per-use 
basis. The Per Use Cost field is used to include 
a charge that is added once for each unit of a 
resource that is assigned to any task. Sounds like 

a mouthful, but the cost per use is a one-time cost 
for a resource used on a task. It is great for one-off 
costs such as a call-out charge for a tradesman or 
the flag-fall charge in a taxi. 

6 

Resource Per Use Cost 

Grader 600 

Air Compressor 200 

Utility 67 

On The Hammer 75 
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ASSIGNING FIXED COSTS 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J410 Costs_4.mpp... 

 Click on the View tab on 
the Ribbon, click on 
Other Views in Task 
Views, and click on 
Task Sheet 

This sheet doesn’t have 
any cost fields so we’ll 
need to adjust the 
table… 

 Click on Tables in Data 
and click on Cost 

This table gives you a 
break up of costs. We’ll 
use it for entering fixed 
costs for a task… 

 Click in Fixed Cost for 
Erect fencing, type 
15900 and press   

 Click in Fixed Cost for 
Pour foundations, type 
895000 and press   

 Click on the Project tab, 
click on Project 
Information and click 
on [Statistics] 

 Click on [Close]  

 

For Your Reference… 

To assign fixed costs for a task: 

1. Display a Task Sheet view with the Costs 
table 

2. Type the appropriate cost into the Fixed 
Cost field for the desired task and press 

  

Handy to Know… 

 You can also set the accrual method in the 
Fixed Cost Accrual field in the Cost table 
so that the costs are accrued either at the 
beginning or the end of the task. 

 

5 

3 

The Per Use Cost field for resources allows you 
to assign a fixed usage cost to a resource. Each 
time you use that resource you incur that fixed 
cost. If you want that cost to occur only once you 

can assign a fixed cost to the task rather than the 
resource. In our case study this is handy for 
contract charges, which have been negotiated for a 
particular activity or task. 

4 
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ASSIGNING MATERIAL COSTS 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file J410 
Costs_5.mpp... 

 Click on the View tab on the 
Ribbon and click on 
Resource Sheet in 
Resource Views 

For all of the materials, the 
turf, the paint, and the fuel, 
we wish to be able to track 
costs as the materials are 
consumed. By assigning a 
cost per metre to Astro Turf, 
Project will use this rate and 
multiply it by the total number 
of metres that we have 
indicated will be required in 
the assignment of the turf… 

 Click in Std. Rate for Astro 
Turf, type 65.27 and press 

  

 Type 8.76 in Std. Rate for 

Paint and press   

 Click in Std. Rate for Diesel 
Fuel, type 1.89 and press 

  

 Type 1.76 in Std. Rate for 
Unleaded Petrol and press 

  

 Click on the Project tab, click 
on Project Information and 
click on [Statistics] 

 Click on [Close]  

 

For Your Reference… 

To assign materials costs: 

1. Display a Resource Sheet view 

2. Type the cost in the Std. Rate field and 
press   

Handy to Know… 

 You can also assign a cost-per-use charge, 
which effectively allows you to create a fixed 
cost for the materials. 

 

5 

2 

In Microsoft Project, costs for materials are 
applied the same way as costs for work 
resources. You can apply the costs using Std. 
rates where Microsoft Project will determine the 

costs based on the usage. This is ideal for 
consumable materials such as nails, timber, fuel 
and the like, and allows you to track expenditure as 
the task progresses. 

6 

These costs are entered as a unit rate in the Std Rate field 

of the resource sheet. Microsoft Project assumes that this is 
a normal rate and multiplies it by the number of units of the 
material assigned to a task. For example, if you enter $5.00 
for paint in the resource sheet, and then assign 20 units in a 
task, Microsoft Project will calculate the cost at $100.00. 
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USING ANOTHER COST TABLE 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J410 Costs_6.mpp... 

 Scroll up to and double-
click on Architect to 
display the Resource 
Information dialog box, 
then click on the Costs 
tab to see the costings of 
this resource 

 Click on the B tab to see 
a different series of costs 

Now our friends the 
architects normally charge 
us an hourly fee. For 
special jobs however, 
such as submitting 
documentation (where 
their proverbials are on 
the line) they up the fee 
(have to pay for the 
Porsche somehow)... 

 Click in Standard Rate  
and type 450  

 Click in Overtime Rate , 

type 450 and press  

 Click on [OK] to record 
the change 

 

For Your Reference… 

To use multiple cost tables: 

1. Double-click on the desired resource, then 
click on the Costs tab 

2. Click on the drop arrow for Cost accrual 

3. Click on the desired table and enter the 

desired rates. Click on [OK]  

Handy to Know… 

 You can specify a percentage rate change in 
a cost rate table from a set date. Once you 
have entered the effective date, type in the 
percentage change in the Standard Rate, 
Overtime Rate and Per Use Cost fields, eg. 
+10% or -7.5%. The actual rate is then 
calculated and appears in the field. 

 

1 

Microsoft Project lets you assign different rates 
for the same resource in the project by creating 
additional cost rate tables for the resource. This 
is useful where a resource may charge different 

rates depending upon the task that they are 
performing. Access to these different tables is 
made available through the Resource Information 
dialog box. 

4 
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APPLYING A DIFFERENT COST TABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J410 Costs_7.mpp... 

 Click on the View tab on 
the Ribbon and click on 
Resource Usage in 
Resource Views 

 Scroll to and click on 
Submit plans for approval 
under Architect, click on 
the Task tab on the 
Ribbon and click on Scroll 
to Task 

 Click on the Format tab on 
the Ribbon and click on 
Cost in the Details group 

 Scroll to the right until you 
can see the last cost entry 
– a value will appear there 
because the resource costs 
are accrued at the end of 
an assignment 

 Double-click on Submit 
plans for approval to 
display the Assignment 
Information dialog box and 
click on the General tab 

 Click on the drop arrow  
for Cost rate table and 
click on B 

 Click on [OK] to use this 
cost table in the task 

 

For Your Reference… 

To apply a different cost table: 

1. Double click on a task and click on the 
General tab of the Assignment Information 
dialog box 

2. Click on the drop arrow  for Cost rate 

table and click on a different table 

Handy to Know… 

 You can have up to 5 cost rate tables for 
each resource and you can create a 
graduated scale of rates if you use them all. 

 

4 

7 

Microsoft Project allows you to specify different 
costs for resources at different times throughout 
the project by using cost rate tables. The default 
Cost rate table applied to resources is ‘A’. If you 

have more than one cost rate table for a resource, 
you will need to specify which table is used for 
different assignments. 

5 
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CHANGING RATES DURING A PROJECT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J410 Costs_8.mpp... 

 Click on the View tab on 
the Ribbon and click on 
Resource Sheet in 
Resource Views 

 Double click on Carpenter 
and click on the Costs tab 

 Click in the Effective Date 
cell in the second row and 
complete the details as 
shown 

 Click on [OK] 

Now let’s see what impact 
this has had on the 
project… 

 Click on Resource Usage 
in Resource Views 

 Click on Erect wall below 
Carpenter, click on the 
Task tab on the Ribbon 
and click on Scroll to Task 

 Scroll right until you can 
see January 

The hours should still show 
45 but the new table will 
have kicked in and the cost 
will be higher 

 

For Your Reference… 

To assign changed rates from a specific date: 

1. Double click on the desired resource 

2. Click on the Costs tab 

3. Click in the next free Effective Date cell and 
enter the relevant date and rate details  

Handy to Know… 

 It can sometimes be hard to track down 
changing rates in a project. If you do have to 
change the rates for a resource make a note 
of it in the Notes field in the Resource 
Information dialog box. Microsoft Project will 
display a notes icon next to resources with 
Notes as a reminder. 

 

3 

6 

Microsoft Project allows you to enter rate 
changes for resources in a project. This is done 
by nominating an effective date for the change 
and then entering the new rates effective from 

that date. Scott Harris has been in detailed 
negotiations with the carpenters' union. The 
carpenters have won themselves a 25% pay rise 
effective from January 1, 2016. 

7 
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ASSIGNING COST RESOURCES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J410 Costs_9.mpp... 

 Click on the View tab on 
the Ribbon and click on 
Gantt Chart in the Task 
Views group 

 Double click on Submit 
plans for approval to 
display the Task 
Information dialog box 
and click on the 
Resources tab 

 Click below Architect, 
click on the drop arrow 

 and click on 
Building Permit 

Since this is a cost 
resource there are no 
units to worry about, 
only a cost value to 
assign… 

 Click in Cost, type 2500 

and press   

 Click on [OK] 

 Repeat the above steps 
and assign the End of 
Project Party at a cost 
of 15500 to the Official 
Opening task 

 

For Your Reference… 

To assign cost resources to a task: 

1. Double click on a task and click on the 
Resources tab 

2. Choose a cost resource in Resource Name 

and enter a cost in the Cost field 

Handy to Know… 

 So why not just enter these amounts as 
Fixed Costs for a task? You can do this, but 
by creating a Cost Resource you can 
actually itemise the fixed costs associated 
with a task. For example, if the party and the 
permits above were assigned as a fixed cost 
you’d only see a total amount for the two. 

 

6 

Microsoft Project also has a separate cost 
resource which can be a little hard to get your 
head around. This is actually a resource that 
appears in the resource pool but doesn’t have a 

cost value until it is assigned to a task. It is great for 
costs that aren’t directly influenced by the duration 
of a task or the usage of other resources. It is 
similar to a fixed cost. 

4 
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VIEWING PROJECT COSTS 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J410 Costs_10.mpp... 

 Click on the Project tab 
on the Ribbon, click on 
Project Information and 
click on [Statistics] to 
see the Project Statistics 
dialog box 

 Click on [Close] 

 Click on the View tab on 
the Ribbon, click on 
Other Views in Task 
Views, and click on Task 
Sheet 

Using a task sheet view 
you can see the cost 
break-down by task… 

 Click on Tables in Data 
and click on Cost 

 Click on Resource Sheet 
in Resource Views, click 
on Tables in Data and 
click on Cost 

Using a resource sheet 
view you can see the cost 
break-down by resource... 

 Click on Gantt Chart in 
Task Views 

 

For Your Reference… 

To review project costs: 

1. Use the Project Statistics dialog box 
(Project  > Project Information) 

2. Display a Task Sheet view with a Cost table 

3. Display a Resource Sheet view with a Cost 
table 

Handy to Know… 

 The views can be printed out if you require a 
quick hard copy summary of the costs. 

 

1 

5 

When all of the costs have been entered you can 
rest assured that there are many ways in 
Microsoft Project for you to view those costs. You 
can use the Project Statistics dialog box to see 

the total project costs. You can use different views 
and tables to see the costs for tasks and also the 
costs for resources. 

4 


