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CHAPTER 4 CREATING TASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A project normally consists of tasks. Tasks are defined as activities 
required to complete your project. 

Tasks are entered in Microsoft Project into rows and columns much 
the same as data is entered into a spreadsheet like Microsoft Excel. 

In this session you will: 

 gain an understanding of tasks and how they are created 

 gain an understanding of the symbols and icons 
associated with tasks 

 gain an understanding of the case study tasks 

 learn how to review an existing project 

 learn how to enter tasks into a project 

 learn how to create summary tasks 

 learn how to create additional summary tasks 

 learn how to move around a task sheet 

 learn how to manipulate summary tasks and outlining 

 learn how to work with the various views of a task table 

 learn how to work with tasks using the Task Information 
dialog box 

 gain an understanding of task durations 

 learn how to enter durations for a task 

 learn how to check project progress and status 

 learn how to enter task milestones. 

INFOCUS 
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UNDERSTANDING TASKS 
 

 

 

 

Tasks are the activities that make up your 
project. They form the very structure of your 
project and it is important that some thought and 
planning goes into their creation. Tasks are 

entered into a project file in a table-like way with 
each task entered into a separate row of its own. 
Tasks are automatically assigned an ID number 
which appears at the left of the table. 

Organising Tasks 

Tasks can be grouped into phases. Microsoft Project allows you to display the phases as well as the 
tasks – the phase headings are actually referred to as summary tasks. 

A summary task is created when the detail tasks below it are demoted in the hierarchy. The 
summary task is automatically calculated to start at the start date of its earliest subordinate and will 
finish at the end date of its latest subordinate. Microsoft Project will also sum all project costs as well 
as calculate summary start and finish dates.  

Now this is where we get into a chicken and egg scenario. Should you enter the phase headings first 
and then the sub-ordinate tasks, or should you enter all of the tasks and then the phase headings 
later? It really doesn't matter; it's horses for courses. 

Entering tasks can be done in two ways: 

 top down, where specific summary tasks are worked out first, and then the detail tasks 
required to complete the summaries 

 bottom up, where the tasks are worked out and then grouped according to specific 
summaries. 

You can elect to enter the tasks first, then the summaries, or you can enter the summaries then 
the tasks. 

When you have both summaries and tasks in a project your project has a hierarchy. Project 
managers traditionally use a hierarchical organisation known as a work breakdown structure to 
identify major components of a project and then the detail required for each of those components. 

The trick is not which you enter first: summaries or tasks. The trick is being organised to begin with. 
It is a good idea to have your task list well and truly determined before you enter it into Microsoft 
Project. 

Scheduling Modes 

Tasks comprise of details such as duration, start date and finish date. In addition tasks are related to 
one another and these relationships together with the durations and dates form the overall project 
schedule.  

In Microsoft Project tasks can be either automatically scheduled, where Microsoft Project takes 
care of assigning and adjusting start and finish times, or manually scheduled where you control 
when dates and times will be adjusted and calculated. 

Tasks can be switched between automatic and manual scheduling at any time. When a new project 
file is created the tasks are manually scheduled as a default. This is indicated in the status bar at the 
bottom left of the screen. 

Manual scheduling only became available in Microsoft Project 2010. Prior to this version projects 
were automatically scheduled. If you open a project in Microsoft Project 2010 that was created in a 
previous version it will still remain automatically scheduled. 
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UNDERSTANDING SCHEDULING ICONS 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As you enter tasks into a project file various icons 
and symbols appear indicating what is going on 
or where there are information shortfalls. These 
icons and symbols appear in the task mode 

column of a task sheet and in the Gantt Chart. The 
Gantt Chart view of Microsoft Project is a good 
place to begin entering tasks. 

Icon/symbol Location Description 

 
Task Mode column A push pin indicates that the task is manually scheduled 

and that all of the information required for scheduling 
has been supplied. 

 
Task Mode column A push pin with a question mark indicates that the task is 

manually scheduled but that further information (such as 
a duration, start or end date) is still required. 

 
Task Mode column This icon indicates that the task is automatically 

scheduled. 

 
Gantt Chart A coloured bar with end caps indicates that the task is 

manually scheduled and that all information has been 
provided for scheduling. 

 
Gantt Chart A coloured bar with no caps indicates that the task is 

manually scheduled but that dates still need to be 
provided 

 
Gantt Chart An end cap indicates that the start date has been 

provided but that there is no start or end date. 

 
Gantt Chart This icon indicates that the task is automatically 

scheduled. 
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THE ROSTADIUM CASE STUDY TASKS 
 

 

 

 

 

In our case study, Scott Harris, the Project 
Manager at The Rostrum, has consulted with his 
project group and together they have determined 
that the construction of the new stadium should 

be broken into five phases. Each of the phases 
(known as summary tasks) and their respective 
tasks are shown in the table below. 

Phase Tasks 

Planning  Create architectural plans 

 Submit plans for approval 

 Order materials 

Site Works  Erect fencing 

 Erect site buildings 

 Clear and level site 

 Prepare drainage infrastructure 

 Prepare cabling infrastructure 

Building Construction  Pour foundations 

 Erect steelwork 

 Erect walls 

 Install roofing superstructure 

 Install roof retracting mechanism 

 Erect seating tiers 

Fit Out  Fit all windows and doors 

 Install electrical cabling 

 Install electrical fittings and fixtures 

 Install all plumbing 

 Install plumbing fittings and fixtures 

 Lay astro turf 

 Erect handrails and fencing 

 Paint rooms, fixtures, fittings, etc 

 Install PA system 

 Install video imaging equipment 

 Fit out control room 

Commissioning  Test roof mechanism 

 Test PA system 

 Test video imaging equipment 

 Test control room equipment 

 Obtain official occupancy certificates 

 Obtain safety certification 

 Official opening 
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REVIEWING THE PROJECT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file 
J403 Tasks_1.mpp... 

 Notice how the Gantt Chart 
timeline in the project 
begins with the week that 
the project commences 
(May 11, 2015) in view 

 Click on the Project tab in 
the Ribbon and click on 
Project Information in the 
Properties group to display 
the Project Information 
dialog box 

The start and finish dates 
here are identical because 
no scheduling has yet been 
done… 

 Click on [Statistics] to see 
the Project Statistics 

 Click on [Close] to close 
the dialog box 

While we are here we’ll 
ensure that manual 
scheduling is switched on… 

 Click on the current 
scheduling mode button at 
the bottom left of the 
screen 

 Click on Manually 
Scheduled 

 

For Your Reference… 

To manually schedule all project tasks: 

1. Click on the current scheduling mode button 
at the bottom left of the screen 

2. Click on Manually Scheduled 

Handy to Know… 

 Get into the habit of reviewing your project 
statistics regularly. This is especially useful 
after entering task durations and 
dependencies. 

 

6 

2 

You are about to enter tasks into a newly created 
project file. Even though this project file is 
currently empty it still contains some basic project 
information that can be reviewed. Reviewing 

project information on a regular basis is a good way 
of ensuring that data is entered correctly. We’ll 
have a look at the information now, and then again 
after the tasks are entered. 

5 
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ENTERING TASKS 
 

 

 

 

 

 

 

 

 

 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file J403 
Tasks_1.mpp... 

 Click on the Task 
Name cell in the first 
line 

 Type Create 
architectural plans 

and press   

Wow! A lot of things 
have happened here. 
A manually scheduled 
task pin has appeared 
with a question mark 
indicating that more 
information is required. 
Also, if the column has 
not been wide enough 
word wrapping will 
occur increasing the 
height of the row… 

 Type Submit plans 
for approval as the 
second task and press 

  

 Enter the remaining 
tasks as shown 

 Hold down the  key 

and press  to 

return to the top left 
corner of the task list 

 

For Your Reference… 

To enter tasks in Gantt Chart view: 

1. Click in the first available task cell 

2. Type the name of the task and press  

  

Handy to Know… 

 Nothing will appear in the Gantt Chart 
because not enough information has been 
provided to draw a timeline. For example, at 
present there are no durations, no start 
dates, and no end dates for the tasks. 

 

1 

2 

There are many ways to enter tasks into a project 
file. However, the Gantt Chart, which is the 
default view, is a good option. In the Gantt Chart 
view the tasks are entered into the sheet view on 

the left of the screen. As you enter a task, a default 
duration of 1 day is automatically assigned to the 
task and a Gantt bar is drawn in the chart on the 
right of the screen. 

4 
3. Order materials 
4. Erect fencing 
5. Erect site buildings 
6. Clear and level site 
7. Prepare drainage infrastructure 
8. Prepare cabling infrastructure 
9. Pour foundations 
10. Erect steelwork 
11. Erect wall 
12. Install roofing superstructure 
13. Install roof retracting mechanism 
14. Erect seating tiers 
15. Fit all windows and doors 
16. Install electrical cabling 
17. Install electrical fittings and fixtures 
18. Install all plumbing 
19. Install plumbing fittings and fixtures 
20. Lay astro turf 
21. Erect handrails and fencing 
22. Paint rooms, fixtures, fittings, etc 
23. Install PA system 
24. Install video imaging equipment 
25. Fit out control room 
26. Test roof mechanism 
27. Test PA system 
28. Test video imaging equipment 
29. Test control room equipment 
30. Obtain official occupancy certificates 
31. Obtain safety certification 
32. Official opening 
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CREATING SUMMARY TASKS 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
J403 Tasks_2.mpp... 

 Click on Create 
architectural plans, hold 
down the left mouse button 
and drag down to Order 
materials to select the 
three tasks 

 Click on the Task tab on 
the Ribbon and click on 
Summary in the Insert 
group to insert a new 
summary task 

 Type Planning as the 
name for the new summary 
task and press   

 Repeat the above steps 
and create the additional 
summary tasks as shown 
on the next page 

 

For Your Reference… 

To create a summary task: 

1. Select the sub-ordinate tasks 

2. Click on the Task tab on the Ribbon and 
click on Summary in the Insert group 

3. Type a name for the summary task and 
press   

Handy to Know… 

 Summary tasks appear as autoscheduled 
tasks. A summary task is calculated using 
the start date of the first task and the end 
date of the last task. As such they have to be 
automatically calculated based on their 
subordinates. 

 

1 

2 

Summary tasks are like headings that represent 
the phases in a project. They also summarise 
information. Summary tasks are general 
headings that have subordinate tasks. 

Subordinate tasks are indented to the right and 
provide a further level of detail for that part of the 
project. Summary tasks can be entered when 
tasks are first entered or at a subsequent stage. 

3 



Microsoft Project 2010 - Module 1 

© Watsonia Publishing Page 44 Creating Tasks 

ASSIGNMENT – CREATING SUMMARY TASKS 
 

 

 

 

 

Using the steps outlined in the previous exercise, 
create the following summary tasks as shown. 
Take care when selecting the required sub-
ordinate tasks. You should check that you have 

selected the correct tasks. If you make a mistake 
use the Undo tool on the Quick Access Toolbar 
to undo the mistake. 
 

Planning 

Create architectural plans 

Submit plans for approval 

Order materials 

Site Works 

Erect fencing 

Erect site buildings 

Clear and level site 

Prepare drainage infrastructure 

Prepare cabling infrastructure 

Building Construction 

Pour foundations 

Erect steelwork 

Erect wall 

Install roofing superstructure 

Install roof retracting mechanism 

Erect seating tiers 

Fit Out 

Fit all windows and doors 

Install electrical cabling 

Install electrical fittings and fixtures 

Install all plumbing 

Install plumbing fittings and fixtures 

Lay astro turf 

Erect handrails and fencing 

Paint rooms, fixtures, fittings, etc 

Install PA system 

Install video imaging equipment 

Fit out control room 

Commissioning 

Test roof mechanism 

Test PA system 

Test video imaging equipment 

Test control room equipment 

Obtain official occupancy certificates 

Obtain safety certification 

Official opening 

 

 

Add 

Add 

Add 

Add 
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WORKING IN A SHEET VIEW 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file J403 
Tasks_3.mpp... 

 Hold down the  key 

and press  to 

return to the top left 
corner of the table 

 Press  to jump 

down one screen 

 Press  to jump up 

one screen 

 Press  to move 

right in the table to the 
last column in the 
current row 

 Press  to move 

left in the table to the 
first column in the 
current row 

 

For Your Reference… 

To move about a sheet view: 

  +  takes you to the top left hand 
corner of the sheet 

  +  takes you to the bottom right 
hand corner of the sheet  

Handy to Know… 

  +  moves the Gantt view to the first 

timeline bar while   +  moves the 

Gantt view to the end of the last timeline bar. 

 

1 

2 

A task sheet displays your data in columns and 
rows. The columns to the left of the Gantt chart 
actually represent part of a sheet. As you scroll 
around and enter or change data you can 

sometimes get lost in a task or resource sheet. 
There are some basic keyboard keys that will help 
you to move about and, if necessary, re-orientate 
the project sheet so that you can get your bearings. 

4 
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WORKING WITH SUMMARY TASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file J403 
Tasks_3.mpp... 

 Click on the View tab 
on the Ribbon and 
click on Outline in the 
Data group to display 
a menu of options 

 Click on Outline Level 
1 to see only the 
summary tasks 

 Click on the plus sign 
 next to Site Works 

to see the detail tasks 

 Click on Outline in the 
Data group and click 
on All Subtasks to 
see everything again 

 

For Your Reference… 

To outline a project: 

1. Click on the View tab on the Ribbon and 
click on Outline in the Data group 

2. Click on the desired option 

Handy to Know… 

 You can also expand or collapse the 
summaries by clicking on the plus or minus 
sign. 

 

1 

2 

Summary tasks allow you to hide unnecessary 
detail. For example, you can collapse a project 
so that the detail tasks below the summary tasks 
are no longer visible. This is an excellent way of 

seeing a bird's eye view of your project. You can 
collapse and expand (display) all of the detail 
tasks, or just specific ones using the tools on the 
toolbar and the summary task headings. 

3 
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WORKING WITH TASK VIEWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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e
 

Continue using the 
previous file with this 
exercise, or open the file 
J403 Tasks_3.mpp... 

 Click on the View tab of 
the Ribbon, click on 
Other Views in the 
Task Views group and 
click on Task Sheet to 
see the tasks in a sheet 
view 

 Click on Tables in the 
Data group and click on 
Schedule to see tasks 
with scheduled dates 

 Click on Tables again 
and click on Cost to see 
the Costs table 

 Use the Tables 
command to examine 
some of the other tables 

 Click on Gantt Chart in 
the Task Views group 
to return to the Gantt 
Chart view 

 

For Your Reference… 

To work with table views: 

1. Click on the View tab, click on Other Views 
in the Task Views group, and click on Task 
Sheet 

2. Click on Tables in the Data group and click 
on the desired table 

Handy to Know… 

 There is a lot of repetition in the dates and 
the scheduling at the moment because no 
proper durations, relationships, or start and 
end dates have been entered. As a 
consequence Microsoft Project defaults to 
using the project’s start date. 

 

1 

2 

In Microsoft Project it is always amazing to see 
how much you get even when entering so little! 
As mentioned before, Microsoft Project is simply 
two database tables, one for tasks and the other 

for resources. Each of these tables contains many 
fields. To see these fields arranged thematically 
you can use one of the many table views available 
on the View tab of the Ribbon.  
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EXAMINING TASK INFORMATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file J403 
Tasks_3.mpp... 

 Click on Create 
architectural plans to 
select the task 

 Click on the Task tab 
on the Ribbon and 
click on Information in 
the Properties group 
to display the Task 
Information dialog 
box 

This dialog box 
provides all of the 
relevant information 
available for a task… 

 Click on the various 
tabs on the dialog box 
and examine the 
options and settings 
that they contain 

 Click on [OK] 

 

For Your Reference… 

To examine task information: 

1. Click on a task to select it 

2. Click on the Task tab on the Ribbon and 

click on Information in the Properties group 

Handy to Know… 

 The Task Information dialog box is often 
used to modify tasks in a project. It provides 
access to all of the fields of a task in one 
convenient location. 

 

1 

2 

Just as Microsoft Project provides you with a 
Project Information dialog box to see key 
information about the overall project, there is also 
a separate Task Information dialog box that 

provides all of the information pertaining to a task in 
one easy location. This dialog box can be accessed 
using the Information command on the Task tab, 
or by double clicking on a task. 
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UNDERSTANDING TASK DURATIONS 
 

 

 

 

 

To be able to create a project schedule you need 
to assign a duration to each of the tasks, tell 
Microsoft Project how the tasks are inter-related 
or dependent upon one another and assign 

resources to complete the tasks. Once durations 
have been entered, Project has sufficient 
information to be able to calculate a critical path 
and determine the amount of slack in the tasks. 

Task Durations 

Once tasks have been entered (or as they are being entered) you can specify the appropriate 
duration details for each task. 

Unless specified otherwise, the default duration as set in the Options dialog box is used. This 
duration is in days, and 1 unit is provided. This is why 1 day has appeared on the tasks that you 
have entered. 

Estimated Durations 

Microsoft Project allows you to enter estimated durations if you wish. Estimated durations appear 
with a question mark at the end of them. The default duration appears with a question mark because 
the duration has been entered by Microsoft Project and requires you to enter the appropriate value 
when you are ready. 

Abbreviations 

You can type the duration in minutes, days, hours, weeks, or months, and you can use a variety of 
abbreviations for these. For example, you can express a day as d, dy, or day, and a week as w, wk, 
or week. Minutes are normally entered as m, while months are entered as mo. 

Units 

Project internally converts the duration to hourly units as defined by the duration of a day and a week 
in the Options dialog box. If the Options dialog box states that a day comprises of 8 hours, and the 
base calendar says that the day starts at 7:30 am and finishes at 4:00 pm with a half hour lunch 
break, and you enter a task with a 10 hour duration, the task will be scheduled according to regular 
working hours. This task will be scheduled to start at 7:30 am and finish at 9:30 am the following day 
– 8 hours on the first day (7:30 – 4:00), and 2 hours on the second day (7:30 – 9:30). 

Elapsed Duration 

You can also specify elapsed duration where the passing of a certain amount of time is important. 
Elapsed duration is based on 24 hours. For example, waiting for paint to dry is best measured as 
elapsed time, rather than the other type of duration, which is based on the hours in a working day. 

The following abbreviations can be used for durations: 

Unit Abbreviation Unit Abbreviation 

Minutes m Elapsed Minutes em 

Hours h Elapsed Hours eh 

Days d Elapsed Days ed 

Weeks w Elapsed Weeks ew 

Months mo Elapsed Months emo 

 

 

 

 

 

 

If you are scheduling down to the hour it helps to actually display hours in the start and 
end time of project tasks. The way dates and time are displayed can be changed in the 
Options dialog box. The Options dialog box is accessed from the Backstage (by 
clicking on the File tab) and clicking on [Options]. The date and time display settings 
are controlled using the Date Format option under Project View on the General tab of 
the Options dialog box. 
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ENTERING TASK DURATIONS 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 F
il
e
 Continue using the 

previous file with this 
exercise, or open the 
file J403 
Durations_1.mpp... 

 Click in the Duration 
cell to the right of 
Create architectural 
plans, type 3w and 

press   

Here we are setting 
the duration of this 
task to 3 weeks… 

 Enter 1mo for Submit 
plans for approval, 
and 8d for Order 
materials 

Notice that the 
summary task has a 
duration derived from 
the task with the 
longest duration – in 
this case 20 days (i.e. 
1 month)… 

 Enter the remaining 
durations as shown 

Note: Do not enter the 
durations for the 
summary tasks as 
these are 
automatically 
calculated… 

 

For Your Reference… 

To enter task durations: 

1. Click in the duration cell of the task 

2. Enter a duration value as a number 
together with the appropriate abbreviation 
(e.g. 4d for 4 days) 

3. Press   

Handy to Know… 

 Notice that the durations of summary tasks 
(the ones in bold) are automatically 
calculated for you as you enter the durations 
for the subordinate tasks. 

 

2 

Once tasks have been entered (or as they are 
being entered) you can enter the appropriate 
duration details for each task. Durations can also 
be entered with a ? suffix. This indicates that the 

duration is a rough estimate. You can later change 
the duration to confirm the estimate. 

3 

Site Works 15 days 

Erect fencing 3 days 

Erect site buildings 4 days 

Clear and level site 3 wks 

Prepare drainage 
infrastructure 1 wk 

Prepare cabling 
infrastructure 1 wk 

Building Construction 60 days 

Pour foundations 4 days 

Erect steelwork 3 mons 

Erect wall 2 mons 

Install roofing 
superstructure 2 wks 

Install roof retracting 
mechanism 1 wk 

Erect seating tiers 3 wks 

 

Fit Out 20 days 

Fit all windows and doors 2 wks 

Install electrical cabling 1 wk 

Install electrical fittings and 
fixtures 2 wks 

Install all plumbing 2 wks 

Install plumbing fixtures and 
fittings 1 wk 

Lay astro turf 1 wk 

Erect handrails and fencing 2 wks 

Paint rooms, fixtures, 
fittings, etc 1 mon 

Install PA system 2 days 

Install video imaging 
equipment 3 days 

Fit out control room 1 wk 

Commissioning 5 days 

Test roof mechanism 1 wk 

Test PA system 2 days 

Test video imaging 
equipment 2 days 

Test control room 
equipment 1 wk 

Obtain official occupancy 
certificates 1 day 

Obtain safety certification 2 days 

Official opening 1 day 
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CHECKING PROGRESS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

Try This Yourself: 

S
a

m
e

 

F
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Continue using the 
previous file with this 
exercise, or open the file 
J403 Durations_2.mpp... 

 Click on the Project tab 
on the Ribbon and click 
on Project Information in 
the Properties group 

 Click on [OK] to close the 
dialog box 

Let’s have a look at the 
scheduling table to see 
what is happening… 

 Click on the View tab on 
the Ribbon, click on 
Other Views in Task 
Views, and click on Task 
Sheet 

 Click on Tables in the 
Data group and click on 
Schedule 

 Click on Gantt Chart in 
Task Views 

 

For Your Reference… 

To check the progress of your project: 

1. Click on the Project tab and click on Project 
Information in the Properties group 

2. Click on the View tab, click on Other Views 
in Task Views, and click on Task Sheet 

3. Click on Tables in the Data group and click 
on Schedule 

Handy to Know… 

 Slack time is that period in a task between 
the earliest date in which a task can start and 
the latest date in which the task can start. 
The period is slack, meaning that the task 
can begin anywhere between the earliest 
and latest start dates. 

 

1 

Working with Microsoft Project involves some 
ritualistic behaviour. For example, you’ll 
constantly be adding or modifying tasks and 
resource data where even the most trivial update 

can cause havoc with a project’s schedule. It is 
therefore imperative that you check project 
progress and status on a regular basis. Our project 
now has durations – let’s see what has happened. 

4 

Notice that our project is now scheduled to finish in July. 
There are still no relationships (or dependencies) 
between the tasks in the project. The finish date is 
therefore calculated from the task that has the greatest 
duration. 

We still haven’t definitely scheduled the tasks. However, 
given that the project should finish in late July, Microsoft 
Project has attempted to calculate slack time for each 
task. 
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ENTERING MILESTONES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e
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Continue using the 
previous file with this 
exercise, or open the file 
J403 Durations_3.mpp... 

 Click on the Site Works 
summary task to select 
it 

 Click on the Task tab on 
the Ribbon and click on 
Milestone in the Insert 
group to create a 
milestone in the project 
at the end of the 
Planning phase 

 Type Planning 
Completed and press 

  

 Repeat the above steps  
and add milestones at 
the end of each of the 
project’s remaining 
phases as shown 

 Press  + , then 

save the project 

 

For Your Reference… 

To create a milestone in a project: 

1. Click in the location for the milestone 

2. Click on the Task tab on the Ribbon and 
click on Milestone in the Insert group 

3. Type a name for the milestone and press 
  

Handy to Know… 

 Milestones have zero duration because they 
are designed to highlight a particular point in 
the project. You can convert any existing 
duration into a milestone by changing its 
duration to zero. 

 

1 

2 

Milestones are significant events that occur in 
your project. A milestone is entered like a normal 
task except that it is assigned a duration of zero. 
Milestones can be entered when you first create 

your project, or, as in our case, after you have 
entered your tasks. Milestones are handy to use 
as reference points in your project to identify key 
targets or goals that have been achieved. 
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Milestone At End Of 

Site Works Completed Site works 

Building Construction Completed Building Construction 

Fit Out Completed Fit out 

Commissioning Completed Commissioning 
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