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CHAPTER 16 RECORDER WORKSHOP 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Macro Recorder can be used to create macros to automate 
your work, or to make a worksheet more user-friendly for 
colleagues. 

Complex calculations can be recorded by an experienced Excel 
operator and then linked to objects on the worksheet to make them 
available to anyone. 

In this session you will: 

 learn how to prepare data for an application 

 learn how to record a summation macro 

 learn how to record consolidations 

 learn how to record macros for specific divisions 

 learn how to test macros 

 learn how to create objects to run macros 

 learn how to assign a macro to an object. 

INFOCUS 
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PREPARING DATA FOR AN APPLICATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

 

Before starting this exercise 
you MUST ensure that Excel 
has started... 

 Click on the File tab of the 
Ribbon and select Open, then 
locate and double-click on 
Expenses East.xlsx to open 
the workbook 

 Repeat step 1 for the following 
workbooks: 

Expenses North.xlsx 

Expenses South.xlsx 

Expenses West.xlsx 

 Spend a few moments 
examining the workbooks 

 Notice that the layout for each 
of the workbooks is the same – 
column and row headings are 
the same, totals exist in the 
same cells in each workbook, 
and the format applied to each 
total cell is the same... 

 Leave the four Expenses 
workbooks open for the next 
exercise 

 

For Your Reference… 

To prepare data for an application: 

1. Review the workbooks to be included, to be 
familiar with the data 

2. If preparing for a consolidation, check that 
the layout of each source workbook is 
identical 

Handy to Know… 

 A data consolidation combines the figures 
from different worksheets/workbooks into a 
summary. For this reason we need the layout 
of each source workbook to be identical. We 
can write macros to consolidate the data in 
different ways such as a total, an average, or 
maximum and minimum figures. 

1 

2 

A series of macros can be put together in a 
workbook to perform related functions. This type 
of workbook is called an application. Before you 
start creating macros for an application, you need 

to check that the data is suitable. For our example, 
a consolidation of the budget figures for four 
divisions, we need to ensure that the layout of each 
source worksheet is identical. 
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RECORDING A SUMMATION MACRO 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file E846 
Recorder Workshop_1.xlsm... 

 On the Developer tab of the 
Ribbon, click on Record 

Macro  in the Code group 

 Complete the macro details as 
shown, then click on [OK] 

 Click on B5, then click on the 
Data tab of the Ribbon and 

click on Consolidate  to 
display the Consolidate dialog 
box 

 Click on the View tab of the 
Ribbon, click on Switch 

Windows  and click on 
Expenses East.xlsx 

 Select range B5:D8, then click 
on [Add] 

 Repeat steps 4 and 5 for 
Expenses North.xlsx, 
Expenses South.xlsx and 
Expenses West.xlsx 

 Click on [OK] to consolidate 
the figures 

 Click on A1, type Sum of All 

Divisions then press  and 

click on Stop Recording  

 

For Your Reference… 

To record a summation macro: 

1. Click on Record Macro  

2. Click on the first cell of the target range and 
perform the consolidation steps 

3. Click on Stop Recording  

Handy to Know… 

 Rather than having to type the cell 
references in the Consolidate dialog box, 

you can click on Collapse Dialog  to give 
you access to the worksheet, enabling you to 
select the appropriate range with the mouse. 

2 
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Any options available on Excel’s Ribbon can be 
turned into macros to avoid the need for 
repetition. In this example, we will record a macro 
that uses the Consolidate option on the Data tab 

of the Ribbon, to reference the figures in four 
worksheets and present the total in a fifth 
worksheet. By recording these steps, we can 
recreate the figures instantly in future. 

6 
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RECORDING CONSOLIDATIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E846 Recorder 
Workshop_2.xlsm... 

 Click on Record Macro  
and complete the Record 
Macro dialog box as shown, 
then click on [OK] 

 Click on B5, then click on the 
Data tab of the Ribbon and 

click on Consolidate  to 
display the Consolidate dialog 
box 

 Click on the drop arrow  for 
Function and select Average 

 As the References are already 
in place from the previous 
macro, we can simply accept 
the rest of the settings... 

 Click on [OK], then click on 
A1, type Average of All 
Divisions and press  

 Click on Stop Recording  

 Repeat steps 1 to 5 for the 
other macros, as shown in the 
table 

 

For Your Reference… 

To apply different consolidation functions: 

1. Click where you want the data to appear 

2. On the Data tab, click on Consolidate  

3. Click on the drop arrow  for Function and 
select the function required 

4. Click on [OK] 

Handy to Know… 

 After performing a consolidation, you have 
no way of knowing how the figures have 
been combined without referring to the 
Consolidate dialog box. By placing a 
heading in A1 we ensure that at any time we 
know which function was the most recently 
applied. 

1 

3 

Once a consolidation has been recorded, it can 
be reused to consolidate the figures in different 
ways. Some of the other options for summarising 
the data are to show average, maximum, 

minimum, count, product (multiplied) and standard 
deviation. For our case study in this workshop we 
will build additional macros that perform the first 
three of these functions on the same set of data. 

Macro Name: MaximumConsolidation 

Macro Shortcut:  +  (lowercase x) 

Consolidation Function: Max 

Text in cell A1: Maximum of All Divisions 

  

Macro Name: MinimumConsolidation 

Macro Shortcut:  +  (lowercase i) 

Consolidation Function: Min 

Text in cell A1: Minimum of All Divisions 
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RECORDING DIVISIONAL MACROS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E846 Recorder 
Workshop_3.xlsm... 

 Click on Record Macro  
and complete the Record 
Macro dialog box as shown, 
then click on [OK] 

 Click on B5, then click on the 
Data tab of the Ribbon and 

click on Consolidate  

 Click on the drop arrow  for 
Function and click on Sum 

 Click on the entry below 
Expenses East.xlsx in All 
references and click on 
[Delete], then repeat until only 
this reference is left 

 Click on [OK] then click on A1, 
type Eastern Division Only 

and press  

 Click on Stop Recording  

 Repeat steps 1 to 6 for the 
macros as shown in the table – 
to change the reference at 
step 5, click on it in All 
references, modify it in the 
Reference field and click on 
[Add]. Click on the previous 
reference and click on [Delete] 
to remove it 

 

For Your Reference… 

To display a single workbook using consolidate: 

1. Click where you want the data to appear 

2. On the Data tab, click on Consolidate  

3. Ensure that Sum is selected in Function 

4. Remove all references except the one you 
require, then click on [OK] 

Handy to Know… 

 You can also consolidate data by category. 
This uses the labels to the left or above the 
values to determine the category. In this 
situation, you can have a list of labels that 
varies, such as expense categories. Values 
with identical labels are consolidated and the 
others are reported individually. 

1 

4 

We have used the data consolidation process to 
combine the data from four source workbooks. If 
you wanted to examine these individually, you 
would need to open them one by one. 

Alternatively, you can write macros that transfer the 
data from one division only into the consolidated 
worksheet. Add a heading at the same time and 
you’ve created one viewing point for all workbooks. 

Macro Name: WestOnly 

Macro Shortcut:  +  +  (uppercase W) 

Reference: Expenses West.xlsx 

Text in cell A1: Western Division Only 

  

Macro Name: NorthOnly 

Macro Shortcut:  +  +  (uppercase N) 

Reference: Expenses North.xlsx 

Text in cell A1: Northern Division Only 

  

Macro Name: SouthOnly 

Macro Shortcut:  +  +  (uppercase O) 

Reference: Expenses South.xlsx 

Text in cell A1: Southern Division Only 
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TESTING MACROS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E846 Recorder 
Workshop_4.xlsm... 

 Press  +  +  to see 

the Sum consolidation 

 Press  +  to see the 

Average consolidation 

 Press  +  to see the 

Minimum consolidation 

 Press  +  to see the 

Maximum consolidation 

 Press  +  +  to see 

the Eastern Division data 

 Press  +  +  to see 

the Western Division data 

 Press  +  +  to see 

the Northern Division data 

 Press  +  +  to see 

the Southern Division data 

 

For Your Reference… 

To test a macro: 

1. Press the corresponding shortcut key 

OR 

1. Click on Macros  on the Developer tab 

2. Select the macro 

3. Click on [Run] 

Handy to Know… 

 Ideally, you should manually calculate a 
sample of the figures to ensure that the 
consolidations are working correctly. Open 
each workbook and compare the figures. 
You’d be surprised at the proportion of 
spreadsheets that have errors – automated 
and all! 

1 

4 

We have developed eight macros for our case 
study. Four of them provide a summary of the 
data as a total, average, maximum or minimum. 
The other four macros display the source data, 

enabling you to drill down a level and review the 
original data, should you want to examine it more 
thoroughly. It is important to test each macro 
before you pass the workbook on to other users. 

8 
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CREATING OBJECTS TO RUN MACROS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous file 
with this exercise, or open the 
file E846 Recorder 
Workshop_5.xlsm... 

 Click on the Insert tab then click 

on Shapes  in the 
Illustrations group to display 
the autoshapes menu 

 Click on the Bevel  shape in 
Basic Shapes to select it – the 
mouse pointer changes to a 
cross-hair 

 Starting at the top left of cell G2, 
use the mouse to draw a 
bevelled rectangle, then type 
Sum Divisions 

 Repeat steps 2 & 3 to create the 
objects shown in the table 

 The Bevel tool now appears on 
the Drawing Tools > Format 
tab... 

 Hold down  and click on 

each object to select them 

 Click on the Drawing Tools: 
Format tab, then click on Align 
and select Align Left 

 On the Drawing Tools: Format 
tab, click on Align and select 
Distribute Vertically 

 Press  to deselect the 
objects 

 

For Your Reference… 

To create an object: 

1. Click on the Insert tab, then click on Shapes 

 

2. Select a shape from the menu 

3. Draw a shape on the worksheet 

4. Type a name in the shape 

Handy to Know… 

 Click on Shape Fill  to change the fill 
colour of a shape. 

 Click on Shape Outline  to change the 
outline of a shape. 

3 

4 

Macros make using workbooks easier – as long 
as you know that they exist! You could show 
someone how to use the shortcut keys or ribbon 
to run macros, but a more user-friendly approach 

is to create an object and link the macro to that 
object. An object can be anything that you can 
place on a workbook, such as a drawn circle, a 
box, a line or even an inserted picture. 

Cell G4: Average Divisions 

Cell G6: Minimum Expenses 

Cell G8: Maximum Expenses 

Cell G10: Eastern Division 

Cell G12: Western Division 

Cell G14: Northern Division 

Cell G16: Southern Division 
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ASSIGNING A MACRO TO AN OBJECT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E846 Recorder 
Workshop_6.xlsm... 

 Click on the Sum Divisions 
shape to select it 

 Right-click on the shape to 
display the shortcut menu and 
select Assign Macro 

 The Assign Macro dialog box 
will be displayed... 

 Click on SumConsolidation 
and click on [OK] 

 Press  to deselect the 
shape then hover over the 
Sum Divisions shape to 
display the mouse pointer 

 Click on the shape to run the 
macro 

 Repeat steps 1 to 5 to assign 
the macros as shown in the 
table 

 Test each of the macro objects 

 

For Your Reference… 

To assign a macro to an object: 

1. Click on the object to select it 

2. Right-click on the object and select Assign 
Macro 

3. Click on the macro name 

4. Click on [OK] 

Handy to Know… 

 You can also assign macros to the Quick 

Access Toolbar. Click on the drop arrow  
for the QAT and select More Commands. 
Click on the drop arrow  for Choose 
commands from and select Macros. Click 

on the macro and click on [Add]. 

2 

4 

Once you have created your macros and the 
objects that you want to link them to, all you need 
to do is assign the macros to the objects. This is 
done via a shortcut menu. When you assign a 

macro to an object, the object becomes ‘live’. 
You’ll notice that the mouse pointer will change to a 
hand as you hover over the object. This is to clearly 
indicate that clicking the object will start an action. 

Shape Macro 

Average Divisions: AverageConsolidation 

Minimum Expenses: MinimumConsolidation 

Maximum Expenses: MaximumConsolidation 

Eastern Division: EastOnly 

Western Division: WestOnly 

Northern Division: NorthOnly 

Southern Division: SouthOnly 
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