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CHAPTER 9 PIVOT TABLES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A PivotTable tool is found in Excel that allows you to analyse data in 
lists. Lists allow you to record data – this could be a list of daily 
sales, a list of songs in your music collection, a list of petty cash 
purchases over the last three months, or whatever. Trying to make 
sense of the data in a small list is fairly straightforward, but when 
your list extends to many dozens, hundreds, or even thousands of 
records, trying to manually analyse the data and extract useful 
information can be tedious. PivotTable Reports provide a way for 
automatically analysing the data found in lists. 

In this session you will: 

 gain an understanding of pivot tables in Excel 

 learn how to create a PivotTable shell 

 learn how to drag fields into a PivotTable shell 

 learn how to filter the data in a PivotTable report 

 learn how to clear a filter in a PivotTable report 

 learn how to switch fields around in a PivotTable 
structure 

 learn how to apply formatting to a PivotTable 

 gain an understanding of Slicers 

 learn how to insert a Slicer. 

INFOCUS 

WPL_E839 



Microsoft Excel 2010 - Level 3 

© Watsonia Publishing Page 84 Pivot Tables 

UNDERSTANDING PIVOT TABLES 
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If you have your data organised into columns and 
rows in Excel you have what is known as a 
database or a list. The first row in the list is used 
for column headings while each row contains a 

separate record of data. In Excel pivot tables can 
be used to analyse lists and ask two-dimensional 
questions where one column of data can be 
compared against another 

The List 

The following list shows the column or field names across the top of the list. Each row in the list is 
equivalent to one record. Our example actually holds 102 records. 

2 Asking the Question 

Pivot tables are used to interrogate (ask questions of) the data in the 
list. For example, from the list above you may want to know how much 
in sales has been made by each salesperson over the three months of 
data in the list. 

The question is phrased by dragging the relevant column headings 
(known as fields) into special areas created in the PivotTable pane. 
The PivotTable pane appears when you tell Excel you wish to insert a 
pivot table, or when an existing pivot table is selected. 

Obtaining the Answer 

Once relevant column fields have been dragged into the fields area, 
Excel will use the data corresponding to the headings from the list to 
perform an analysis and answer the question. 

In the example below, the Salesperson field has been dragged to the 
Row Labels area, and the Month field has been dragged to the 
Column Labels area. 

As soon as the Price field was dragged to the Values area, the pivot 
table summed all of the price amounts by month and salesperson and 
also created grand totals as shown. We now know that Hector Smith 
made 61,358 in the month of February. 
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CREATING A PIVOTTABLE SHELL 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file E839 
Pivot Tables_1.xlsx... 

 Click anywhere in the list of 
sales – this will enable Excel to 
determine the fields and 
records that can be used in the 
pivot table 

 Click on the Insert tab of the 
Ribbon and click on 

PivotTable  to display the 
Create PivotTable dialog box 

 This dialog box is used to 
specify where to place the 
PivotTable… 

 Ensure that Select a table or 
range and also New 
Worksheet are both selected, 
then click on [OK] to display a 
new sheet with a PivotTable 
shell and the PivotTable pane 

 

For Your Reference… 

To create a PivotTable shell: 

1. Click anywhere in the list 

2. Click on the Insert tab of the Ribbon and 

click on PivotTable  

3. Nominate the location for the table and click 
on [OK] 

Handy to Know… 

 It is usually best to place the pivot table in a 
separate worksheet away from the main list 
to avoid accidentally losing data from the list 
when working with the table, and to avoid 
disrupting the table when working with the 
list. 
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PivotTables perform their analytical operations 
in a defined structure that resembles a table. The 
PivotTable structure can be placed either in the 
current worksheet or in a new sheet in the 

workbook. When the structure, which we’ll refer to 
as a shell, is selected a PivotTable pane will 
appear showing the fields that can be dragged into 
the shell for use in analysis. 
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DROPPING FIELDS INTO A PIVOTTABLE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
E839 Pivot Tables_2.xlsx... 

 Move the mouse pointer 
onto the Month field in the 
PivotTable pane until the 
mouse pointer appears 
with four arrows 

 Hold down the left mouse 
button and drag the Month 
field to the Column Labels 
area in the pane 

 The months will now 
appear as columns in the 
shell… 

 Drag the Salesperson field 
to the Row Labels area in 
the pane 

 The salesperson names 
will now appear in the left 
column of the shell… 

 Drag the Price field to the 
Values area in the pane 

 Excel will sum the price 
(sales) by month and by 
salesperson 

 

For Your Reference… 

To drop fields into a PivotTable shell: 

1. Click on the desired field in the PivotTable 
pane 

2. Drag the field into the Column Labels, Row 
Labels, or Values area of the pane as 
required 

Handy to Know… 

 You can also place fields into a PivotTable 
shell by double-clicking them in the 
PivotTable pane. This method is less 
precise than dragging and is not 
recommended until you are really 
comfortable with PivotTable operations. 

1 

4 

Pivot tables work by analysing two or more 
variables – these variables are usually the fields 
from a list. Once a PivotTable shell has been 
constructed the variables (fields) required for the 

analytical operation can be dragged to the shell 
using the PivotTable pane that appears when the 
PivotTable shell is selected. 

2 
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FILTERING A PIVOTTABLE REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E839 Pivot 
Tables_3.xlsx... 

 Move the mouse pointer to the 
Age Grouping field in the 
PivotTable pane and drag the 
field to the Report Filter area 
of the pane 

 Click on the drop arrow  that 
has appeared to the right of 
Age Grouping (All) in the 
worksheet – a list of all values 
in the field will now appear 

 Click on 25 or less then click 
on [OK] to see the summed 
sales for customers aged 25 or 
under 

 Repeat step 3 for some of the 
other age groupings 

 Click on the filter button  at 
the right of Age Grouping to 
see the filter list and click on 
Select Multiple Items until it 
appears with a tick 

 Click on the options until both 
(and only) 46 – 55 and 55 or 
over appear with a tick, then 
click on [OK] 

 

For Your Reference… 

To filter a PivotTable report: 

1. Drag the filter field to the Report Filter area 

2. Click on the filter drop arrow  in the 
PivotTable report 

3. Click on the filter criteria and click on [OK] 

Handy to Know… 

 There are also filter drop arrows for Column 
Labels and Row Labels. In the example 
above if you clicked on the drop arrow for 
Column Labels you would see the names of 
the months (Jan, Feb, Mar). 

1 

2 

Unless you specify otherwise, all of the data in a 
list will be analysed when you create or modify a 
PivotTable report. You can set up your 
PivotTable report to work only with specific data 

by applying a filter. This can be done by dragging 
an additional variable (field) to the Report Filter 
area in the PivotTable pane. 
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CLEARING A REPORT FILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file E839 Pivot 
Tables_4.xlsx... 

 Click on the filter button  
at the right of Age Grouping 
in the worksheet, to see the 
filter list 

 Click on Select Multiple 
Items until it appears without 
a tick 

 Click on All then click on 
[OK] to see all of the data 
summed again 

 If you no longer require a 
filter you can remove the 
entire filter structure from the 
table… 

 Move the mouse pointer to 
the Age Grouping field in 
the Report Filter area in the 
PivotTable pane and drag 
the field listing back to the 
Field list at the top of the 
pane 

 Notice that the Age 
Grouping field label has also 
been removed from the 
worksheet 

 

For Your Reference… 

To clear a report filter: 

1. Click on the filter button  at the right of the 
filter field in the table 

2. Click on All 

3. Click on [OK] 

Handy to Know… 

 You can also remove Row Labels and 
Column Labels by dragging them out of 
their respective areas in the PivotTable 
pane. 

1 

Report filters provide another dimension to 
PivotTable reports allowing you to be selective in 
the data that is actually analysed. When you no 
longer require the filtering operation you can 

simply advise the filter that you wish to see all of 
the data again, or, if you no longer need to retain 
the filter, remove the entire filter field from the 
Report Filter area. 

4 
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SWITCHING PIVOTTABLE LABELS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file E839 Pivot 
Tables_5.xlsx... 

 Move the mouse pointer to 
Salesperson in the Row 
Labels area of the 
PivotTable pane and drag 
the field up into the fields 
listing at the top of the pane 

 Notice now how only the 
Column Label totals are left 
in the table… 

 Drag the Payment Method 
field, from the field list in the 
PivotTable pane, to the Row 
Labels area 

 You should now see sales by 
Payment Method over the 
three months… 

 Drag the Payment Method 
field up to the field listing, 
then drag Make from the field 
listing to the Row Labels 
area 

 You should now see the 
sales by Make of vehicle 
over the three months 

 

For Your Reference… 

To modify the structure of a PivotTable: 

1. Click on a field in either the Row or Column 
Labels area and drag it to a different location 
in the PivotTable pane 

Handy to Know… 

 Wondering what Defer Layout Update on 
the PivotTable pane does? If this option is 
ticked, changes made to the structure of the 
table aren’t seen in the worksheet until 
[Update] is clicked. This can be used on 
super large lists which may take a while to 
recalculate. 

1 

3 

PivotTables are all about asking questions of the 
data in a list. However, the game is far from over 
once you’ve created a PivotTable. At any time 
you can modify the Row or Column Labels 

essentially asking a brand new question of the 
existing PivotTable report. When you add or 
remove fields, the PivotTable will automatically 
analyse the data based on the new settings. 
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FORMATTING A PIVOTTABLE REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file E839 Pivot 
Tables_6.xlsx... 

 Click on the PivotTable 
Tools: Design tab of the 
Ribbon, then click on 
Banded Rows in the 
PivotTable Style Options 
group until it appears with a 
ticked 

 Coloured bands should now 
appear in the PivotTable… 

 Click on the Banded 
Columns command to apply 
column bands in the 
PivotTable 

 Remove the tick from both 
Banded Rows and Banded 
Columns to remove the 
banding 

 Move the mouse pointer over 
various options in the 
PivotTable Styles group – 
the PivotTable displays a 
preview of that style 

 Once you have found a style 
that you are satisfied with, 
click on it to apply it to the 
PivotTable 

 

For Your Reference… 

To format a PivotTable return: 

1. Click on the Design tab of the Ribbon 

2. If you want bands, click on the relevant 
banding command until it is ticked 

3. Choose a PivotTable Style 

Handy to Know… 

 You can also use the standard formatting 
options for worksheets rather than apply a 
global style or banding. 

1 

2 

PivotTable reports can be cryptic creatures at the 
best of times, especially with the jargon and 
terminology used. The comprehension of a 
PivotTable is not always helped by the standard 

formatting applied by Excel. Fortunately, using 
the options on the Design tab of the Ribbon you 
can really jazz up a PivotTable report and in the 
process make it more understandable. 
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UNDERSTANDING SLICERS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

While it’s an odd sounding name a Slicer is really 
just a very special filter that can be applied to a 
PivotTable listing. Slicers slice through your 
data providing instant cross-referencing views. 

Admittedly these cross-reference views can be 
created by more traditional PivotTable filters, but 

the new Slicers make the task very easy indeed. 

What Is A Slicer 

When you create a Slicer for a PivotTable Excel will place a new graphics object on the worksheet. 
The object is just a rectangle with a series of filter buttons. There is a button for each unique 
example of data in the field you have chosen for your Slicer.  

 

A Slicer is a filter for one field of your table. In the example above a Slicer has been created for the 
Salesperson field. Since there are three sales people in the table a filter button is created for each 
salesperson. In the example above the filter button for Hector Smith has been clicked and Excel 
displays the monthly sales by make of vehicle for Hector in the PivotTable report. 

What’s really neat with Slicers, is that you can have more than one Slicer associated with your 
report as shown below. 

 

 

In the example above three Slicers have been created – one Salesperson, one for Type (of vehicle), 
and another for Year (of vehicle manufacture). With this type of Slicer you could work out the total 
sales of 1999 coupes by Hector, or the total SUV sales by Justin, and the like. 
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CREATING SLICERS 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this 
exercise you MUST 
open the file E839 Pivot 
Tables_7.xlsx... 

 Click anywhere in the 
PivotTable in the 
worksheet 

 Click on the Insert tab 
on the Ribbon and click 
on Slicer to display the 
Insert Slicers dialog box 

 Click on the tick box for 
Salesperson and click 
on [OK] to display a 
Slicer box with the 
salespeople in it 

 Click on Hector Smith 
to see only the sales 
made by Hector 

 Click on Mary O’Dwyer 
to see only the sales 
made by her 

 Click on the Clear Filter 

button  to see all of 
the sales again 

 

For Your Reference… 

To insert a Slicer: 

1. Click anywhere in the PivotTable 

2. Click on the Insert tab and click on Slicer 

3. Tick the field(s) to slice and click on [OK] 

Handy to Know… 

 You can filter on more than one field. To do 
this click on the first sample, then hold down 
the  key and click on subsequent 

samples. 

 

2 

Slicers are special field filters that can be applied 
to Excel tables. They are most useful for further 
dissecting an existing PivotTable report in a 
worksheet. Slicers are actually graphics objects 

comprising of a rectangle and special filter buttons. 
Slicers are inserted into the worksheet from the 

Slicer command on the Insert tab of the Ribbon. 
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