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CHAPTER 6 SUMMARISING AND SUBTOTALLING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Spreadsheets are often used to store data in a list – in rows and 
columns. Often there is a need to provide grand totals at the 
bottom and subtotals throughout the data – as a summary. 

Summarising in a structured worksheet has traditionally been done 
by: typing the data in a logical sequence; creating a formula for the 
subtotal of each subsection and; creating a grand total at the bottom 
of the list. 

Since many of the operations are routine, special features have 
been added to Excel to perform these steps for you. 

In this session you will: 

 learn how to create subtotals 

 learn how to use a subtotalled worksheet 

 learn how to create nested subtotals 

 learn how to copy subtotals using Go To 

 learn how to use subtotals with autofilter 

 learn how to create relative names to use with subtotals 

 learn how to use relative names to create subtotals. 

INFOCUS 
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CREATING SUBTOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file E836 
Summarising_1.xlsx... 

 Click on the Banking Details 
worksheet tab 

 We want to create Subtotals 
for the banks, so first we need 
to sort on that column... 

 Click on any cell in the Bank 
column 

 On the Home tab of the 
Ribbon, click on Sort & Filter 

 in the Editing group and 
select Sort A to Z 

 Now that the data is sorted by 
the Bank column, let’s add 
subtotals for each bank... 

 Click on the Data tab, then 

click on Subtotal  in the 
Outline group, to display the 
Subtotal dialog box 

 Click on the drop arrow  for 
At each change in and click 
on Bank, then ensure the 
other settings are as shown 

 Click on [OK] 

 An outline will appear in the 
worksheet and the Amount will 
be subtotalled at each change 
in Bank 

 

For Your Reference… 

To create subtotals: 
1. Click in the column to be grouped by 

2. On the Home tab, click on Sort & Filter  
and click on Sort A to Z 

3. On the Data tab, click on Subtotal  
4. Select the At each change in column and 

click on [OK] 

Handy to Know… 

 If you realise that you don’t want subtotalling, 
or have forgotten to sort the list first, you can 

click on Undo Subtotals  in the Quick 
Access Toolbar. Alternatively, you can click 

on [Remove All] in the Subtotal dialog box. 
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Subtotalling in Excel automatically outlines and 
totals data that is presented in a list. This is done 
by applying outlining to the list, adding a new row 
at each change in the data and applying the 

SUBTOTAL function to perform the calculations. 
For this to work, the column headings must be 
unique, there should be no blank cells and the data 
must be sorted by the column to be grouped. 
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USING A SUBTOTALLED WORKSHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file E836 
Summarising_2.xlsx... 

 Click on the level 1 outline 
button  to see the grand 
total only 

 Click on the level 2 outline 
button  to see the grand 
total and subtotals for each 
bank 

 Click on the level 3 outline 
button  to see all of the 
data 

 You can use the expand 
and collapse buttons to 
control a single group... 

 Click on the level 2 outline 
button  to see bank totals 

 Click on expand  to the 
left of ANZ Total to reveal 
the ANZ transactions 

 Click on collapse  to the 
left of ANZ Total to display 
only the total again 

 Click on the level 3 outline 
button  to see all of the 
data again 

 

For Your Reference… 

To work with a subtotalled worksheet: 

 Click on a level button    to show that 
level of detail for the entire list 

 Click on expand  or collapse  to work 
with individual subgroups of the list 

Handy to Know… 

 The subtotal figures are created using the 
SUBTOTAL function. The first parameter in 
this function is 9 which tells Excel to SUM the 
figures. The alternatives include calculating 
the average, maximum, minimum and 
product. 
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When a worksheet is subtotalled, outlining is 
applied to help group data and subtotals are 
created as well. You can therefore use all of the 
features of outlining to work with the worksheet – 

hiding detail if necessary to display only subtotals. 
Outlining provides expand and collapse buttons 
as well as level buttons that can be used to quickly 
display data at a specific level. 
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CREATING NESTED SUBTOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the file 
E836 Summarising_3.xlsx... 

 Click on any data cell then, on the 
Home tab, click on Sort & Filter 

 and select Custom Sort 

 Click on [Add Level] 

 Click on the drop arrow  for 
Then by and click on Date, then 
click on [OK] 

 As subtotals already exist in the 
worksheet, the Sort operation will 
have to remove them first... 

 Click on [OK] 

 Click on the Data tab, then click 

on Subtotal  to display the 
Subtotal dialog box 

 Click on the drop arrow  for At 
each change in, click on Bank 
and click on [OK] 

 Let’s add a second subtotal... 

 Click on Subtotal  and select 
Date in At each change in 

 Click on Replace current 
subtotals, until it appears without 
a tick, and click on [OK] 

 Now both Bank and Date 
subgroups are subtotalled 

 

For Your Reference… 

To create nested subtotals: 

1. Sort the data according to the primary and 
secondary groupings 

2. Create the subtotal for the primary group 

3. Create the subtotal for the secondary group, 
without replacing the current subtotals 

Handy to Know… 

 If you select the option Page breaks 
between groups in the Subtotal dialog box, 
Excel will insert a page break at the start of 
each group so that you can print each on a 
separate page. It will also include vertical 
page breaks indicating how much of the data 
will fit across a portrait page. 
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You can create quite complex subtotalling with 
more than one subtotal on a group. This involves 
nesting the subtotals that you create. The first 
step is to sort the data on the main grouping and 

then on the secondary grouping. In this example, 
the data is sorted first by Bank and then by Date. 
Within each bank grouping, the date subgroups will 
display a separate subtotal. 
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COPYING SUBTOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E836 Summarising_4.xlsx... 

 Click on the level 2 outline 
button  to display subtotals 
for each bank, then select 
D1:F126 

 On the Home tab, click on Find 

& Select  in the Editing 
group and select Go To 
Special, to display the Go To 
Special dialog box 

 Click on Visible cells only until 
it appears selected, then click 
on [OK] 

 While the highlighting does not 
appear to change, it now 
includes only the selected 
cells... 

 On the Home tab, click on 

Copy  in the Clipboard 
group 

 Click on the Insert Worksheet 
worksheet tab to insert a new 
sheet 

 Press  to paste the 

subtotals into the new 
worksheet 

 Double-click on the column 
borders between each of the 
columns A, B and C to adjust 
the column widths 

 

For Your Reference… 

To select and copy the subtotals: 

1. Select the range to copy 

2. On the Home tab, click on Find & Select 

 then select Go To Special 

3. Click on Visible cells only and click on [OK] 

4. Copy and paste the cells as usual 

Handy to Know… 

 You could copy the grand total when copying 
subtotals by including it in the selection. 
However, remember that only the values are 
pasted into the new worksheet not the 
formulas, so any changes you make to the 
subtotals in the copied version will not 
update the grand total. 

2 

4 

Once you have created subtotals, there are a 
number of things that they can be used for. For 
instance, you may want to chart the subtotals or 
perform additional analyses on them. To protect 

the original data, it is wise to copy the subtotals to 
another location first. The trick is to use a special 
Go To feature to select only the subtotal cells, 
otherwise you’ll end up copying the detail as well. 

7 
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USING SUBTOTALS WITH AUTOFILTER 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E836 Summarising_5.xlsx... 

 Click on the Banking Details 
worksheet tab, then click on D1 
to deselect the cells 

 Click on the Data tab, then click 

on Subtotal  and click on 
[Remove All] to remove all 
subtotals 

 Click on Filter  in the Sort & 
Filter group to display the 
autofilter drop arrows 

 Click on the drop arrow  for 
Date, select Date Filters then 
select Custom Filter to display 
the Custom AutoFilter dialog 
box 

 Click on the drop arrow  for 
Date and click on is after or 
equal to, then press  and 

type 8/1/08 

 Repeat step 5 to add the 
second condition: is before or 
equal to 10/1/08 

 Click on [OK] to apply the date 
range filter 

 Click on Subtotal , click on 
the drop arrow  for At each 
change in and click on Bank, 
then click on [OK] 

 

For Your Reference… 

To use subtotals with a filtered list: 

1. Sort the data as required 

2. On the Data tab, click on Filter  and apply 
a filter 

3. Create subtotals as required 

Handy to Know… 

 It is important to remember to sort the data in 
the required order prior to applying a filter 
and subtotals. 

3 
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You may find a situation where you are working 
with a filtered list and want to create subtotals 
for a particular subset of the data. For example, if 
you want to group records within a particular date 

range, you can create a custom autofilter first to list 
the required records and then apply subtotals to 
create the summary. 

8 
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CREATING RELATIVE NAMES FOR SUBTOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E836 Summarising_6.xlsx... 

 Click on the Statements 
worksheet tab, then click on F4 

 We want to create relative range 
names so that we can create a 
running balance using formulas 
for each change in customer... 

 Click on the Formulas tab of the 
Ribbon, then click on Name 

Manager  to display the 
Name Manager dialog box 

 Click on [New] to display the 
New Name dialog box 

 Type Customer in Name, press 

 three times and type 

=$B:$B in Refers to, then click 
on [OK] 

 Repeat steps 3 and 4 for the 
column range names: 

Debit =$D:$D 

Credit =$E:$E 

Balance =$F:$F 

 Repeat steps 3 and 4 for the row 
range names: 

This =4:4 

Previous =3:3 

Next =5:5 

 Click on [Close] 

 

For Your Reference… 

To create names: 

1. Position the cell pointer (for relative names) 

2. Click on the Formulas tab, click on Name 

Manager  and click on [New] 

3. Type a Name 

4. Type a cell Reference and click on [OK] 

Handy to Know… 

 To create just one range name, click on 

Define Name  in the Defined Names 
group on the Formulas tab of the Ribbon. 
This will display the New Name dialog box 
enabling you to create a single name. 
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An absolute range name is the most common 
type of range name. It refers to a specific cell or 
range as an absolute address (e.g. $A$4 or 
$A$2:$D$6). You can also create relative range 

names, where names move from one part of the 
worksheet to another with the formulas that refer to 
them. The position of the cell pointer when you 
create a relative reference is very important. 
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USING RELATIVE NAMES FOR SUBTOTALS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E836 Summarising_7.xlsx... 

 Click on F4 and type =Debit-
Credit+IF(Customer=Previous 
Customer, Previous Balance) 

 Press  to see the result 

 It should read $456.00. Now to 
copy it down the column... 

 Click on F4, then drag the fill 
handle (bottom right corner of 
the cell) to F20 to copy the 
formula 

 Click on A4 and type 
=IF(Customer=Previous 
Customer,””,Customer) 

 Press  then drag the fill 

handle to copy the formula from 
A4 to A20 

 Click on G4 and type 
=IF(Customer=Next 
Customer,””,Balance) 

 Press  (nothing will 

appear), then click on F4 

 Click on the Home tab, click on 

Format Painter  then click 

on G4 (still nothing will appear) 

 Drag the fill handle to copy the 
formula from G4 to G20 

 

For Your Reference… 

To use relative names in formulas: 

1. Replace cell references with range names 

2. Fill-in other cells as required 

Handy to Know… 

 The range names that you create will appear 
listed in the Name Box located to the left of 
the Formula Bar. By selecting the name 
from the list, Excel will highlight the related 
cells. 

1 
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While range names are usually created to refer to 
a specific part of the worksheet, relative range 
names refer to a range relative to the position of 
the cell pointer at the time they were created. 

This makes them ideal for special types of formulas 
where you want the name to move with the 
formula. This example demonstrates how to use 
formulas and relative names to create subtotals. 
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