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CHAPTER 10 WORKSHEET TECHNIQUES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Excel workbooks are three-dimensional. They have rows, columns 
and worksheets. The rows and columns that form a worksheet 
are the two core dimensions. A workbook can be made up of 
multiple worksheets – forming a third dimension. 

The ability to have a number of worksheets in a workbook allows 
you to separate your data according to use and purpose. For 
example, different worksheets can be used for raw data, 
consolidated data, list of assumptions, constants and charts. 

To be able to create and manage a three-dimensional workbook 
effectively, you need to master a number of worksheet techniques. 

In this session you will: 

 learn how to insert and delete worksheets 

 learn how to copy a worksheet 

 learn how to rename a worksheet 

 learn how to move a worksheet 

 learn how to hide a worksheet 

 learn how to unhide a worksheet 

 learn how to copy a worksheet to another workbook 

 learn how to move a worksheet to another workbook 

 learn how to change worksheet tab colour 

 learn how to group worksheets 

 learn how to hide rows and columns 

 learn how to restore rows and columns that have been 
hidden 

 learn how to freeze and unfreeze rows and columns 

 learn how to split windows. 
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INSERTING AND DELETING WORKSHEETS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file E824 
Worksheets_1.xlsx... 

 Examine the worksheet – it 
currently contains one 
worksheet named Sheet1 

 Click on the Insert 
Worksheet  icon – this can 
be located at the end of the 
worksheet tabs 

 A new worksheet is inserted – 
by default, this sheet is 
named Sheet2. You can also 
use the keyboard shortcut... 

 Press  +  to insert 

another new worksheet 

 This sheet is named Sheet3 
and is inserted before the 
currently selected sheet. Now 
let’s delete a sheet... 

 Right-click on the Sheet3 
worksheet tab to display the 
shortcut menu 

 Select Delete to remove the 
worksheet 

 As the worksheet contains no 
data, the sheet is deleted 
immediately. If a worksheet 
contains data, Excel will ask 
you to confirm your actions... 

 Repeat steps 4 and 5 to 
delete Sheet2 

 

For Your Reference… 

To insert a worksheet: 

1. Click on the Insert Worksheet  icon OR 

2. Press  +  

To delete a worksheet: 

1. Right-click on the worksheet tab and select 
Delete 

Handy to Know… 

 Alternatively, to insert a worksheet between 
existing worksheets, right-click on the 
worksheet tab before which you want to 
insert a new sheet and select Insert to 
display the Insert dialog box. Select 
Worksheet and click on [OK]. This method 
also enables you to insert other objects. 

1 

2 

Once you’ve settled on a structure for your 
workbook, you may find that you have some 
worksheets that can be deleted. Alternatively, 
you may find that you need additional blank 

worksheets inserted. However, users beware: 
deletion of worksheets is permanent and can’t be 
undone! Save your workbook before making these 
changes. 
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COPYING A WORKSHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the file 
E824 Worksheets_2.xlsx... 

 Click on Sheet1 to select it 

 Let’s copy this worksheet... 

 On the Home tab, click on 

Format  in the Cells group to 

display the menu 

 Select Move or Copy Sheet in 
Organise Sheets to display the 
Move or Copy dialog box 

 Click on Create a copy until it 
appears with a tick, then click on 
[OK] 

 The new worksheet is named 
Sheet1 (2). Let’s create a 
template from this worksheet... 

 Select the range B7:E9 and press 
 to clear it 

 Repeat step 5 to clear the ranges 
B14:E23, G7:J9 and G14:J23, 
then press  +  

 Now let’s copy the template... 

 Repeat steps 2 to 4 three times to 
create three copies of the 
worksheet 

 The final worksheet should be 
named Sheet1 (5) 

 

For Your Reference… 

To copy a worksheet: 

1. Click on the worksheet tab to copy 

2. On the Home tab, click on Format  in the 
Cells group 

3. Click on Create a copy until it is ticked 

4. Click on [OK] 

Handy to Know… 

 To place a copy of the selected worksheet 
after the existing worksheets, click on (move 
to end) in the Move or Copy dialog box. 

 To copy a worksheet to another workbook, 
open the workbook before copying. It will 

then appear in the Move or Copy dialog box. 

1 
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Just as you can copy the contents of cells and 
ranges within a worksheet, you can copy 
worksheets within a workbook. This technique is 
ideal for replicating layouts. For example, if you 

have a budget workbook that contains data for 
several departments, you can create a worksheet 
for the first department and then copy it to create 
identical worksheets for other departments. 

7 
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RENAMING A WORKSHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E824 
Worksheets_3.xlsx... 

 Move the mouse pointer to the 
bar between the sheet names 
and the horizontal scroll bar 

 The pointer will change to a 
double-headed arrow... 

 Click and drag the bar across 
to the right, to the end of 
column G then release the 
mouse button 

 Double-click on Sheet1 (5) to 
select the worksheet tab name 
– this will also place it into edit 
mode 

 Type Comms then press  

 Repeat steps 3 and 4 to 
rename the other worksheets: 

Sheet1 (4) Admin 

Sheet1 (3) Shop 

Sheet1 (2) IT 

Sheet1 Maintenance 

 

For Your Reference… 

To rename worksheets: 

1. Double-click on a worksheet name 

2. Type the new name 

3. Press  

Handy to Know… 

 You can also rename a worksheet by 
right-clicking on the worksheet tab to display 
the shortcut menu. Then click on Rename. 

 A worksheet tab name can contain up to 31 
characters including spaces. 

1 

2 

By default, Excel provides three worksheets in 
each new workbook. These are named Sheet1, 
Sheet2 and Sheet3. These names are fine if you 
are not planning to share the workbook, but 

worksheet tab names make it much easier to 
understand the purpose of a worksheet. You can 
also adjust the horizontal scroll bar to make room 
for longer, more meaningful worksheet names. 

3 
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MOVING A WORKSHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_4.xlsx... 

 Click on the Admin worksheet 
tab to select the worksheet 

 Let’s move it before Comms... 

 On the Home tab, click on 

Format  in the Cells group, 

then select Move or Copy 
Sheet 

 Ensure that Comms is selected 
in Before sheet, then click on 
[OK] 

 You can also move sheets by 
dragging them into place... 

 Click on the Shop tab to select 
the worksheet, then hold down 

 and click on the IT tab 

 This selects both worksheets... 

 Move the mouse pointer over 
either tab and drag to the left 
until the small black arrow 
appears between Admin and 
Comms 

 Release the mouse button to 
move the worksheets 

 Repeat steps 5 and 6 to move 
the Maintenance worksheet 
between Admin and Shop 

 

For Your Reference… 

To move a worksheet: 

1. Select the worksheet(s) 

2. Drag the worksheet(s) into place OR 

2. On the Home tab, click on Format  then 
select Move or Copy Sheet 

3. Click on a sheet in Before sheet and click 
on [OK] 

Handy to Know… 

 You can select a continuous range of 
worksheets by clicking on the first worksheet 
tab in the range, then holding down  and 

clicking on the last worksheet tab in the 
range. Holding  enables you to select a 

non-continuous range of worksheets. 

2 

3 

Moving a worksheet refers to the process of 
changing the order of the worksheets in the 
workbook. There are times when you may want 
to reorganise the worksheets in a workbook to 

match the business hierarchy, or to retain a 
chronological order. Worksheets can be dragged 
into position, one or more at a time, or moved via 
the Move or Copy dialog box. 

5 
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HIDING A WORKSHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_5.xlsx... 

 Click on the Maintenance 
worksheet tab to select the 
worksheet 

 Note that there are currently 
five worksheet tabs visible... 

 On the Home tab, click on 

Format  in the Cells group 

to display the menu 

 Select Hide & Unhide in 
Visibility to display the 
submenu 

 Select Hide Sheet 

 The worksheet disappears and 
Shop becomes the active tab 

 

For Your Reference… 

To hide a worksheet: 

1. Click on the worksheet tab 

2. On the Home tab, click on Format  in 

the Cells group 

3. Select Hide & Unhide in Visibility 

4. Select Hide Sheet 

Handy to Know… 

 If you want to hide more than one worksheet 
simultaneously, you can select multiple 
sheets by clicking on the first sheet in the 
range and then holding either  or  

and clicking on the other sheets. You can 
then hide the sheets as normal. 

1 

3 

Hiding a worksheet is good, for example, if you 
want to hide lookup tables or special calculations 
so that the user is not distracted by the detail or 
tempted to make any unnecessary changes. You 

might like to hide specific departmental worksheets 
so that they are not visible to other departments. 
One worksheet in a workbook, however, must 
always be visible. 

4 
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UNHIDING A WORKSHEET 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_6.xlsx... 

 Look at the worksheet tabs – 
notice that there are currently 4 
tabs visible 

 On the Home tab, click on 

Format  in the Cells group 

to display the menu 

 Select Hide & Unhide in 
Visibility, then select Unhide 
Sheet to display the Unhide 
dialog box 

 Ensure that Maintenance is 
selected in Unhide sheet, then 
click on [OK] 

 The Maintenance worksheet tab 
is redisplayed and becomes the 
active worksheet 

 

For Your Reference… 

To unhide a worksheet: 

1. On the Home tab, click on Format  

2. Select Hide & Unhide in Visibility then 
select Unhide Sheet 

3. Click on the worksheet name then click on 

[OK] 

Handy to Know… 

 It is not possible to unhide more than one 
worksheet at a time. 

 You can also right-click on a worksheet tab 
to display the shortcut menu and select 

Unhide to display the Unhide dialog box. 

1 

3 

Although it is possible to hide worksheets in a 
workbook, you must always keep at least one 
worksheet visible. It is not obvious by simply 
looking at a workbook if any worksheets are 

hidden, but by displaying the Unhide dialog box all 
the hidden worksheets will be listed. It is then a 
simple matter of selecting the worksheet that you 
want to make visible again. 

4 
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COPYING A WORKSHEET TO ANOTHER WORKBOOK 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_7.xlsx... 

 Click on the Maintenance 
worksheet tab to select the 
worksheet 

 Let’s copy this completed data 
to another workbook... 

 On the Home tab, click on 

Format  in the Cells group 

to display the menu 

 Select Move or Copy Sheet in 
Organise Sheets to display the 
Move or Copy dialog box 

 Click on the drop arrow  for To 

book and click on (new book) 

 Click on Create a copy until it 
appears with a tick 

 This will create a new workbook 
as well as making a copy of the 
worksheet... 

 Click on [OK] 

 A new workbook will be created 
and Maintenance will be the 
only worksheet in the 
workbook… 

 Save the new workbook as 
Maintenance.xlsx 

 

For Your Reference… 

To copy a worksheet to another workbook: 

1. Select the worksheet to copy 

2. On the Home tab, click on Format  then 

select Move or Copy Sheet 

3. Select the Book and position 

4. Click on Create a copy and click on [OK] 

Handy to Know… 

 To copy a worksheet into an existing 
workbook, make sure that you open the 
destination workbook to ensure that it is 
listed in To book in the Move or Copy 
dialog box. 

1 

3 

You can copy worksheets to other workbooks 
as required. For example, you might need to 
keep records for six different divisions – rather 
than send each division the entire set of records, 

you can copy their worksheet to another workbook 
and send them their data only. If worksheets exist 
in the other workbook, you will need to determine 
the order in which to place the copied worksheet. 

5 
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MOVING A WORKSHEET TO ANOTHER WORKBOOK 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_8.xlsx... 

 Click on the Notes worksheet 
tab in E824 Worksheets_8.xlsx 
to select the worksheet 

 On the Home tab, click on 

Format  in the Cells group 

 Select Move or Copy Sheet to 
display the Move or Copy 
dialog box 

 Click on the drop arrow  for 

To book and click on 
Maintenance.xlsx 

 Click on (move to end) in 
Before sheet 

 This will place the worksheet 
after the existing worksheet 
(Maintenance) in the destination 
workbook... 

 Click on [OK] 

 The Maintenance.xlsx workbook 
will be displayed with the Notes 
worksheet active. The Notes 
worksheet will no longer exist in 
the source document: E824 
Worksheets_8.xlsx 

 

For Your Reference… 

To move a worksheet to another workbook: 

1. Select the worksheet to move 

2. On the Home tab, click on Format  then 

select Move or Copy Sheet 

3. Select the Book and position 

4. Click on [OK] 

Handy to Know… 

 You can move more than one worksheet at 
the same time. Click on one worksheet tab to 
select the worksheet, then hold down  

and click on the worksheet tabs for the other 
sheets that you want to move. Move the 
selected sheets as normal. 

1 

3 

You can move worksheets to other workbooks 
as required. For example, you might need to 
summarise the records for six different divisions 
and, rather than send management the entire set 

of records, you can move the summary worksheet 
to another workbook and send just the summary. 
The moved worksheet will retain any links that exist 
in formulas to cells in the other workbook. 

5 
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CHANGING WORKSHEET TAB COLOURS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_9.xlsx... 

 Click on the Admin tab to select 
the worksheet 

 On the Home tab, click on 

Format  in the Cells group 

 Select Tab colour to display the 
colour palette 

 Click on Red in Standard 
colours to apply the colour to 
the tab 

 You can also use a shortcut to 
change worksheet tab colour... 

 Right-click on the Maintenance 
worksheet tab to display the 
shortcut menu 

 Select Tab colour then click on 
Blue in Standard colours 

 Repeat either technique to apply 
the following colours: 

Shop Yellow 

IT Green 

Comms Purple 

 Click on the Admin worksheet 
tab to view the results 

 

For Your Reference… 

To change worksheet tab colour: 

1. Select the worksheet tab 

2. On the Home tab, click on Format  

3. Select Tab colour and select a colour OR 

1. Right-click on the worksheet tab 

2. Select Tab colour and select a colour 

Handy to Know… 

 To apply the same colour to two or more 
sheets at once, select them first. Hold down 

 to select consecutive worksheets or 

hold down  to select non-consecutive 

worksheets. 

3 

5 

To make it easier for you to distinguish 
worksheets, Excel enables you to colour code 
worksheet tabs. This enables you, for example, 
to quickly distinguish between different financial 

years, departments or months. The active sheet 
will be underlined in the selected colour, while 
inactive tabs will display a solid colour background. 

8 
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GROUPING WORKSHEETS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_10.xlsx... 

 Click on the Admin worksheet 
tab, hold down  then click 

on the IT worksheet tab to 
select the first four worksheets 

 Click on A1 to select the cell 

 On the Home tab, click on 

Format  in the Cells group 

 Select Format Cells to display 
the Format Cells dialog box 
then click on the Font tab 

 Click on Bold Italic in Font 
Style, then click on the drop 
arrow  for Colour and click 
on Green 

 Click on [OK] to apply the 
changes 

 Click on the other worksheet 
tabs to see that the changes 
have transferred to all selected 
sheets 

 Click on the Comms worksheet 
tab to see that the changes 
have not been applied to this 
worksheet – this also deselects 
the group 

 

For Your Reference… 

To group worksheets: 

1. Click on the first worksheet tab 

2. Hold down  and click on the last 

worksheet tab 

Handy to Know… 

 You can also use  to group worksheets 

that are arranged non-consecutively in a 
workbook. 

 To deselect a group, either click on the tab of 
a worksheet that is not in the group, or right-
click on a tab and select Ungroup Sheets. 

1 

7 

Worksheet grouping enables you to make the 
same change at once to all selected worksheets. 
This is ideal for situations where your worksheets 
have identical layouts or text. For example, if you 

want to format or change the heading for multiple 
worksheets, you simply group the worksheets, 
make a change to one worksheet and the other 
worksheets will reflect the change also. 

8 
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HIDING ROWS AND COLUMNS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file E824 
Worksheets_11.xlsx... 

 Click on column header B then 
drag the mouse to column 
header E to select columns 
B:E 

 Hold down  and click on 

column headers G, H, I and J 

 On the Home tab, click on 

Format  in the Cells group  

 Select Hide & Unhide then 
select Hide Columns to hide 
the columns 

 Now let’s hide some rows... 

 Select rows 14:23 by dragging 
the mouse down the 
respective row headers 

 Hold down  and click on 

row headers 7, 8 and 9 

 Repeat step 3, then select 
Hide & Unhide and select 
Hide Rows to hide the rows 

 Now you can examine the 
totals without having to see the 
detail 

 

For Your Reference… 

To hide rows or columns 

1. Select the row/column header(s) 

2. On the Home tab, click on Format  in 

the Cells group, then select Hide & Unhide 

3. Select Hide Columns or Hide Rows 

Handy to Know… 

 You can also hide a row or column by 
changing the row height or column width to 
zero. 

 You can also hide a row or column by right-
clicking on the selected row or column, then 

clicking on Hide. 

1 

4 

Rows and columns can be hidden from view for 
a number of reasons. Firstly, you may want to 
hide the cells that hold the detail values and just 
show the totals. You may want to protect 

sensitive data, such as pay scales, from 
modification or the public eye. You can hide 
columns so that their contents are still accessible, 
but are not visible on the screen and do not print. 

7 
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UNHIDING ROWS AND COLUMNS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_12.xlsx... 

 Examine the column and row 
headers in Sheet1 – notice that 
there are several columns and 
rows currently missing (hidden) 

 Let’s unhide them… 

 Click and drag the mouse 
pointer over column headers A 
to L to select the columns 

 Currently there are only four 
columns in this range as others 
are hidden in between… 

 On the Home tab, click on 

Format  in the Cells group 

 Select Hide & Unhide, then 
select Unhide Columns to 
unhide the columns 

 Click and drag the mouse 
pointer over row headers 6 to 
24 to select the rows 

 There are currently rows hidden 
in this range… 

 Repeat step 3, then select Hide 
& Unhide and select Unhide 
Rows to unhide the rows 

 All of the worksheet rows and 
columns should now be visible 

 

For Your Reference… 

To unhide rows and columns: 

1. On the Home tab, click on Format  in 

the Cells group 

2. Select Hide & Unhide 

3. Select Unhide Columns or Unhide Rows 

Handy to Know… 

 To quickly unhide all columns or all rows, 
press  +  to select all rows and 

columns and then unhide the rows or 
columns as usual. 

1 

6 

Rows or columns that have been hidden from 
view in a worksheet are still there – they just can’t 
be seen. It is almost as if their relative row or 
column height has been shrunk to zero. 

Unhiding rows and columns involves selecting 
the adjacent rows or columns and then using the 

Hide & Unhide command to see them again. 
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FREEZING ROWS AND COLUMNS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the file 
E824 Worksheets_13.xlsx... 

 Spend a few moments examining 
the worksheet 

 Depending on your screen, it is 
likely that you won’t be able to see 
all of the figures on the screen at 
once... 

 Click on B6 to select the cell 

 This cell is below and to the right 
of the headings... 

 Click on the View tab then click on 

Freeze Panes  in the Window 

group and select Freeze Panes 

 Thin black lines appear above and 
to the left of the selected cell. This 
indicates that the areas above and 
to the left are frozen... 

 Scroll to the right until Yearly 
Average in column L appears next 
to column A 

 Scroll down until Overheads in 
row 25 is below row 5 

 Press  +  to move to B6 – 

this is our temporary home cell 

 On the View tab, click on Freeze 

Panes  and select Unfreeze 

Panes to unfreeze the rows and 
columns 

 

For Your Reference… 

To freeze and unfreeze panes: 

1. Click in the cell below and to the right of the 
area you want to freeze/unfreeze 

2. On the View tab, click on Freeze Panes  

in the Window group and select Freeze 

Panes or Unfreeze Panes 

Handy to Know… 

 If you want to freeze only the rows above the 
selected cell (leaving all columns unfrozen), 
select the cell in column A of that row – e.g. 
to freeze rows 1 to 6, click on cell A7. The 
same applies to freezing only columns and 
leaving the rows unfrozen: select the cell in 

row 1. 

2 

3 

When you lay out your data in rows and columns, 
it is most likely that your headings end up at the 
top or at the left of your data. If you have a large 
amount of data, you may find that when you 

scroll across or down to particular cells, the 
headings scroll out of view. This problem can be 
resolved by freezing the rows and/or columns that 
hold the headings. 

5 
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SPLITTING WINDOWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous file 

with this exercise, or open the 
file E824 Worksheets_14.xlsx... 

 Click on cell F12 

 On the View tab, click on Split 

 in the Window group 

 The window splits into 4 panes, 
with two sets of scroll bars... 

 Use the right horizontal scroll bar 
to move Yearly Average to the 
right of the vertical split bar 

 Use the lower vertical scroll bar 
to move Overheads to just 
below the horizontal split bar 

 Click on D7, type 5000 and 
press  - the total also 

changes 

 On the View tab, click on Split 

 to remove the splits 

 Let’s try a single split... 

 Hover over the vertical split bar 
at the right edge of the horizontal 
scroll bar – the pointer changes 
to a double-headed arrow 

 Drag the split bar between 
columns C and D to create two 
panes 

 Double-click on the split bar to 
remove the split 

 

For Your Reference… 

To split a window in four: 

1. Click on the cell where you want the split 

2. On the View tab, click on Split  

To remove splits: 

1. On the View tab, click on Split  

Handy to Know… 

 You can quickly create a horizontal split by 
dragging the horizontal split bar down into 
position. This split bar is located at the top of 
the vertical scroll bar. 

2 

4 

When you split a window, you actually divide 
the screen into separate working areas. You are 
able to scroll to any part of the worksheet in any 
of the panes. This method is ideal if you want to 

be able to modify figures and see the end result at 
the same time. You can split windows vertically or 
horizontally to form two panes, or both vertically 
and horizontally to form four panes. 
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