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CHAPTER 4 FORMULA TECHNIQUES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Most people are familiar with simple formulas such as =B2+B3 and 
simple functions such as SUM, but there is so much more that you 
can do with formulas and functions. Most functions require 
parameters – extra bits of information – to perform their task. You 
can actually use other functions or formulas as the parameters for a 
function – effectively nesting functions within functions. 

In this session you will: 

 gain an understanding of how to scope a formula 

 gain an understanding of how to develop a nested 
function 

 learn how to create a nested function 

 learn how to edit a nested function 

 learn how to copy nested functions 

 learn how to use concatenation to join text and values 

 learn how to switch to manual recalculation 

 learn how to force a recalculation 

 learn how to paste values from formulas. 

INFOCUS 

WPL_E818 
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SCOPING A FORMULA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A nested function is a function within a function, 
and they can be quite tricky to read and build 
unless you plan ahead. Scoping refers to the 
process of defining the problem or calculation so 

that you can identify the different parts of the 
formula you need to create. The order in which 
these parts need to be calculated determines 
where each part is nested in the formula. 

Scoping & Building Steps 

Formulas that use nested functions are best built in several stages and should be thoroughly tested 
at each stage to ensure that they achieve the correct result. The steps are: 

1. determine what the overall formula will calculate 

2. break down the formula into its component parts 

3. create the base function and ensure that it works 

4. add the additional functions and elements of the formula one by one, testing each one as it 
is added to the overall formula. 

Nesting Functions Workshop Example 

The objective of the workshop example is to create a formula that calculates a dividend payable to 
ten superannuation investors. The spreadsheet includes the following information: 

The dividend is calculated by applying a percentage to the original investment. The percentage is 
taken from a sliding scale and is determined by: 

 the amount of the investment 

 the investment scale that the investor chose 

 the date of initial investment: as an incentive, a 5% bonus was offered to investors who signed 
up on or before June 30, 1998. 

The base function in the formula will be a VLOOKUP function, which is written as follows:  

VLOOKUP(lookup value, lookup table, return value) 

The lookup value is the amount of the investment. The lookup table is the dividend table. The 
return value is the percentage that will be applied to the investment amount to calculate the 
dividend. 

The return value, however, causes a problem as it depends upon the scale chosen by the investor. 
This problem is overcome by using an IF function to ascertain which scale was chosen and to use 
this information to select the appropriate value from the table. 

Another IF function can be used to test whether the investor signed up within the bonus period and 
to apply the appropriate bonus amount. 
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DEVELOPING A NESTED FUNCTION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The best way to develop a complex formula is 
by developing each of the components first and 
then combining them. By writing each of the parts 
in sentence form, you will be able to understand 

the logic of each more easily. You can then 
establish where the individual parts go in the 
overall scheme of your formula, create a base 
function, and then build your formula from there  

Developing the Workshop Example 

The overall formula for the workshop example can be stated as: 

 =Investment Amount * (Dividend Percentage + Bonus) 

The Dividend Percentage 

The logic of the Dividend Percentage calculation can be stated as: 

 Look up the investment amount in the dividend table 

 If the investor chose scale A, then return the percentage from column 2 in the table 

 If the investor chose scale B, then return the percentage from column 3 

 Otherwise, return the percentage from column 4 

The base function used to calculate the Dividend Percentage can be written as: 

 VLOOKUP(investment amount, dividend table, return column) 

The Investment Scale 

We then need to add IF functions within the VLOOKUP to allow for the three scales. If there were 
only two scales, the IF function could be written as: 

 IF(scale chosen = A, return column 2, otherwise return column 3) 

Because there are three scales, we need to add the second IF function to provide the extra choice. 
The final IF functions can be written as: 

 IF(scale chosen = A, return column 2, IF(scale chosen = B, return column 3, return column 4)) 

The Bonus 

Finally, we need to determine whether or not to pay the Bonus. The logic of the Bonus calculation 
can be stated as: 

 If the joining date is earlier than the bonus date, then add 5%, otherwise add nothing 

This can also be done using an IF function, written as: 

 IF(the joining date is earlier than the bonus date, pay 5%, otherwise don’t pay anything) 

Now all we need to do is translate these into Excel terminology and add cell references. We will start 
by creating the base function, so that it can be tested, and then we will add the additional parts of the 
formula. 
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CREATING NESTED FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n

 

F
il

e
 Before starting this exercise 

you MUST open the file E818 
Formula Techniques_1.xlsx... 

 Click in cell G12 

 Type 
=VLOOKUP(E12,$D$3:$G$8, 

 Press  +  to create a 

new line – splitting the parts of 
the formula up makes it easier 
to read 

 Type IF(F12="A",2, 

 Press  +  to create a 

new line 

 Type IF(F12="B",3, 

 The final part of the formula is 
the ‘false’ part of the last IF 
statement… 

 Type 4))) 

 Press  to complete the 

formula 

 The value 0.02 should appear 
– the rate taken from G5 which 
is the $10,000 investment at 
Scale C… 

 Click in cell F12, type A then 

press  to see the dividend 

rate for scale A 

 

For Your Reference… 

To create a nested function: 

1. Type the function as required 

2. Use  +  to create new lines 

3. Check the placement of brackets carefully 

Handy to Know… 

 Excel uses colour in formulas to indicate cell 
references. When you edit an existing 
formula, the cells referred to will appear 
outlined in a specific colour, and the 
corresponding cell references in the formula 
will appear in matching colours. 

3 

4 

A nested function is created by placing a 
function as a parameter within another function. 
When you create nested functions the placement 
of brackets is especially important and should be 

checked carefully. Excel helps you with this task by 
using different colours for matched pairs of 
brackets. You can also improve the readability of 
the formula by placing the parts on separate lines. 

7 
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9 
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EDITING NESTED FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous file 
with this exercise, or open the file 
E818 Formula 
Techniques_2.xlsx... 

 Click on G12 to select it 

 Click immediately after the first 
equal sign in the Formula bar 

 This places the formula in edit 
mode and displays matched 
coloured references. For example, 
$D$3:$G$8 appears in green in 
the formula and is outlined in 
green on the worksheet… 

 Type E12*( 

 This ensures that the investment 
amount will be multiplied by the 
Dividend percentage… 

 Click on  at the right end of the 

Formula bar to expand it, then 
click at the end of the formula and 
press  +  

 On the new line, type 
+IF(D12<=$B$3,5%,0)) 

 This adds the bonus percentage if 
the start date is earlier than the 
bonus date… 

 Press  to complete the 

formula then click on  to restore 
the formula bar to one line 

 

For Your Reference… 

To edit a nested function: 

1. Click on the cell to select it 

2. Click in the formula in the Formula bar and 
edit as required 

3. Press  to complete the changes 

Handy to Know… 

 When you have finished editing a formula, 

you can click on the Enter button  to enter 
the formula. If you make a mistake, you can 

click on the Cancel button  or press  to 

exit from Edit mode. 

2 

4 

Once the base function has been created and 
tested, the additional parts of the nested function 
can be added by editing the formula. Nested 
functions are edited the same way as any other 

Excel formula. When you click on the cell, the 
formula is displayed in the formula bar and can 
then be modified. Excel also uses coloured 
references to help you understand the formula. 

5 
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COPYING NESTED FUNCTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous file 
with this exercise, or open the 
file E818 Formula 
Techniques_3.xlsx... 

 Click on G12 then click on 

Expand Formula Bar  and 
examine the formula 

 The only absolute references 
are $D$3:$G$8, and the Bonus 
date $B$3. The rest are relative 
which will adjust as you copy the 
formula. These include the date 
joined, investment amount and 
scale… 

 Click on Collapse Formula Bar 

 to return it to one line 

 Move the mouse pointer to the 
fill handle at the bottom right 
corner of G12 then double-click 
to copy the formula down the 
column 

 This technique for copying works 
as long as you have a 
continuous list on the left of the 
original cell… 

 Click on G22 then double-click 

on the AutoSum tool  to 
calculate the total of the 
dividends 

 AutoSum will create a Sum 
function for the cells immediately 
above it 

 

For Your Reference… 

To copy a nested function: 

1. Check the cell references 

2. Copy the formula using your preferred 
copying technique 

Handy to Know… 

 When you double-click on a formula, it will 
place it in Edit mode. Cells referred to in the 
formula will appear with coloured outlines. 
If you want the formula to use exactly the 
same cells as those outlined, no matter 
where the formula is copied to, the cell 

references must be absolute. 

1 

3 

You can copy formulas with nested functions 
the same way that you copy any formula. 
However, you should be especially careful of the 
cell addresses. Relative cell addresses will adjust 

automatically when you copy files, while absolute 
addresses will remain unchanged. These can be 
difficult to identify in a complex formula, so it is wise 
to check the results thoroughly after copying. 

4 
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USING CONCATENATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous file 
with this exercise, or open the 
file E818 Formula 
Techniques_4.xlsx... 

 Click on H11 and type Report, 
then press  

 In cell H12, type the following, 
using  +  to create new 

lines, and including the spaces 
before and after the words 

=C12 & " " & B12 & 
" joined the fund on " & 

 Complete the rest of the function 
as shown 

 Press  to create the formula 

 Copy the formula to the range 
H13:H21 and then click 
elsewhere, to deselect it 

 A report has been created for 
every investor 

 

For Your Reference… 

To concatenate text and values: 

1. Use ampersand (&) to add items 

2. Enclose actual text in quotation marks, 
including spaces 

3. Convert dates and values using TEXT() 

Handy to Know… 

 You could use the report created by the 
concatenation in a mail merge using 
Microsoft Word to produce individual report 
letters for each client. 

2 

3 

Concatenation is the process of joining text 
and/or values together. This can be used to form 
a phrase or expression from existing data in the 
worksheet. The main character used for 

concatenation is the ampersand &. All text must be 
enclosed in quotation marks. The TEXT() function 
can be used to convert dates and values into text 
so that they can be included in the result too. 

5 



Microsoft Excel 2010 - Level 2 

© Watsonia Publishing Page 34 Formula Techniques 

SWITCHING TO MANUAL RECALCULATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E818 Formula 
Techniques_5.xlsx... 

 Click on F13 and type B then 

press  

 The dividend and total will 
update to reflect the change... 

 Click on the Formulas tab in 
the Ribbon and click on the 

Calculation Options tool  

to display the menu 

 You can see that it’s set to 
Automatic… 

 Select Manual, then click in 
F16 

 Type A and press  

 You’ll notice that nothing 
changes, even though scale A 
gives a different percentage 
and should result in a higher 
dividend 

 

For Your Reference… 

To switch to manual recalculation: 

1. Click on the Formulas tab 

2. Click on Calculation Options  

3. Select Manual 

Handy to Know… 

 The Calculation settings are global and will 
affect every spreadsheet you work with. You 
can’t force only one workbook to require 
manual recalculation without affecting others 
(unless you’ve done some fancy 
programming, but that’s another story). 

1 

2 

Recalculation refers to processing the formulas 
in a spreadsheet to calculate new results. 
Formulas are usually recalculated each time a 
value in a dependent cell changes, but you can 

turn off automatic recalculation and instead set 
Excel to manual. This means that no formulas will 
be recalculated unless you specifically request 
Excel to perform the calculations. 

4 
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FORCING A RECALCULATION 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file E818 
Formula Techniques_6.xlsx... 

 Click on F20 and examine the 
scale, dividend and total 
amounts 

 Type A and press  

 Nothing happens... 

 On the Formulas tab, click on 

Calculate Now  

 The formulas will be 
recalculated and the results 
will be updated... 

 Click on Calculation Options 

 and select Automatic 

 Now recalculation will happen 
automatically when values are 
changed 

 

For Your Reference… 

To force a recalculation: 

1. Click on the Formulas tab 

2. Click on Calculate Now  or press  

Handy to Know… 

 To recalculate the current worksheet, click on 

Calculate Sheet  on the Formulas tab or 

press  + . To recalcuate all workbooks 

irrespective of changes, press  +  + 

. To check the formulas as well as 

recalculate, press  +  +  + . 

1 

2 

If you turn off manual recalculation, you will need 
to force recalculation at some stage to update 
the formulas. There are several options to 
choose from for recalculation. You can 

recalculate any changed formulas in the current 
worksheet or all open workbooks, recalculate all 
formulas in all workbooks irrespective of changes, 
or check all formulas before recalculating. 

3 
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PASTING VALUES FROM FORMULAS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file E818 Formula 
Techniques_7.xlsx... 

 Select the range B12:B21 then 
hold down  and select 

G12:G21 

 The first part of the range 
contains text and the second 
contains formulas... 

 Click on the Home tab on the 

Ribbon and click on Copy  

 Click on B24, then click on the 

drop arrow for Paste  and 

click on Values  

 Press  to hide the copy 

marquees, then click on C24 
and check the entry in the 
Formula bar 

 You’ll see that only the value 
500 has been pasted – the 
formula isn’t retained 

 

For Your Reference… 

To paste values from formulas: 

1. Click on the formula 

2. Click on Copy  

3. Click in the destination cell 

4. Click on the drop arrow for Paste  and 

click on Values  

Handy to Know… 

 When you copy formulas, you have the 
option to paste formulas, values and links. A 
link is a reference to the cell containing the 
formula. For example, if the cell containing 
the copied formula is G12, the link created by 
pasting will be =$G$12. 

1 

3 

Sometimes it’s useful to be able to grab the 
results of a calculation and use the value 
elsewhere in a spreadsheet without keeping the 
formula. For example, you may want to keep a 

copy of some data at a certain point in time, 
knowing that it won’t change at a later date. You 
can do this by copying formulas and pasting only 
the values. 

4 


